Re: [PATCH v5 2/4] Introduce "double conversion during merge" more gradually
On 1. juli 2010, at 18:25, Junio C Hamano <gitster@pobox.com> wrote:
Show 12 quoted lines
> Johannes Sixt <j.sixt@viscovery.net> writes:
>
>> Am 7/1/2010 11:09, schrieb Eyvind Bernhardsen:
>>> +core.mergePrefilter::
>>
>> BTW, any particular reason that this is in the core namespace rather than
>> merge namespace? It could be merge.prefilter.
>
> Good point.
>
> Somehow to me "prefilter" does not sound to convey what really is going on
> here, though.
"Doubleconvert" doesn't really mean anything either though, and "convert" and "normalise" are too generic. I think the problem is that there's no existing name for what convert.c does.
I chose "filter" because of the filter property; the crlf and ident things can be regarded as built-in filters.
--
Eyvind