Re: [PATCH] prepare deprecation of git-revert
- From
Jakub Narebski <jnareb@gmail.com>
- Date
- Oct 31, 2008, 16:36 UTC
- Message-ID
- <m33aichgc1.fsf@localhost.localdomain>
- In-Reply-To
- <1225468527-29694-1-git-send-email-madcoder@debian.org>
Pierre Habouzit <madcoder@debian.org> writes:
Show 10 quoted lines
> * Rename builtin-revert.c into builtin-cherry-pick.c > > * Add option -R/--revert to git-cherry-pick. > Document it by taking the current content of git-revert manpage for the > option. > > * get rid of the no_replay initialization, just ignore it when we're in > the revert case, it makes really no sense to error out. > > * put the warning of deprecation in cmd_revert, #if 0-ed out for now.
> +#if 0
> + warning("git revert is deprecated, please use git cherry-pick --revert/-R instead");
> +#endifBy the way, Mercurial names this command IIRC 'hg backout'.
But I think that adding '-R' option to git-cherry-pick is a good idea even if we don't go deprecating git-revert.
-- Jakub Narebski Poland ShadeHawk on #git