Re: [PATCH] prepare deprecation of git-revert
- From
Pierre Habouzit <madcoder@debian.org>
- Date
- Oct 31, 2008, 16:54 UTC
- Message-ID
- <20081031165401.GC627@artemis.corp>
- In-Reply-To
- <m33aichgc1.fsf@localhost.localdomain>
On Fri, Oct 31, 2008 at 04:36:33PM +0000, Jakub Narebski wrote:
Show 21 quoted lines
> Pierre Habouzit <madcoder@debian.org> writes:
>
> > * Rename builtin-revert.c into builtin-cherry-pick.c
> >
> > * Add option -R/--revert to git-cherry-pick.
> > Document it by taking the current content of git-revert manpage for the
> > option.
> >
> > * get rid of the no_replay initialization, just ignore it when we're in
> > the revert case, it makes really no sense to error out.
> >
> > * put the warning of deprecation in cmd_revert, #if 0-ed out for now.
>
> > +#if 0
> > + warning("git revert is deprecated, please use git cherry-pick --revert/-R instead");
> > +#endif
>
> By the way, Mercurial names this command IIRC 'hg backout'.
>
> But I think that adding '-R' option to git-cherry-pick is a good idea
> even if we don't go deprecating git-revert.Actually part of the "Git UI sucks at time"-talk by pasy, we somehow decided that git-revert would probably be deprecated in the future to avoid the clash between what people coming from other's SCM worlds expect it to be.
I don't remember what the tentative schedule was, that's why I left the warning commented out for now.
-- ·O· Pierre Habouzit ··O madcoder@debian.org OOO http://www.madism.org