Re: [PATCH] prepare deprecation of git-revert
On Fri, Oct 31, 2008 at 03:55:27PM +0000, Pierre Habouzit wrote:
Show 39 quoted lines
> * Rename builtin-revert.c into builtin-cherry-pick.c
>
> * Add option -R/--revert to git-cherry-pick.
> Document it by taking the current content of git-revert manpage for the
> option.
>
> * get rid of the no_replay initialization, just ignore it when we're in
> the revert case, it makes really no sense to error out.
>
> * put the warning of deprecation in cmd_revert, #if 0-ed out for now.
>
> Signed-off-by: Pierre Habouzit <madcoder@debian.org>
> ---
>
> I've not kept the auto-edit feature of git-revert for the git-cherry-pick -R
> case as I don't believe it makes a lot of sense. But if people are unhappy
> with that, I can easily "fix" it.
>
> Documentation/git-cherry-pick.txt | 15 +++++++++++++++
> Makefile | 6 +++---
> builtin-revert.c => builtin-cherry-pick.c | 10 ++++------
> 3 files changed, 22 insertions(+), 9 deletions(-)
> rename builtin-revert.c => builtin-cherry-pick.c (98%)
>
> diff --git a/Documentation/git-cherry-pick.txt b/Documentation/git-cherry-pick.txt
> index 837fb08..2d92f2d 100644
> --- a/Documentation/git-cherry-pick.txt
> +++ b/Documentation/git-cherry-pick.txt
> @@ -40,6 +40,21 @@ OPTIONS
> development branch), adding this information can be
> useful.
>
> +-R::
> +--revert::
> + Given one existing commit, revert the change the patch introduces, and
> + record a new commit that records it. This requires your working tree
> + to be clean (no modifications from the HEAD commit).
> ++
> +Note: 'git revert' is used to record a new commit to reverse the
^ this was supposed to spell out 'git cherry-pick -R' of course :/
Show 7 quoted lines
> +effect of an earlier commit (often a faulty one). If you want to
> +throw away all uncommitted changes in your working directory, you
> +should see linkgit:git-reset[1], particularly the '--hard' option. If
> +you want to extract specific files as they were in another commit, you
> +should see linkgit:git-checkout[1], specifically the 'git checkout
> +<commit> -- <filename>' syntax. Take care with these alternatives as
> +both will discard uncommitted changes in your working directory.
--
·O· Pierre Habouzit
··O madcoder@debian.org
OOO http://www.madism.org