Re: [PATCH 00/13] submodule: convert the rest of 'update' to C
- From
Atharva Raykar <raykar.ath@gmail.com>
- Date
- Oct 15, 2021, 09:13 UTC
- Message-ID
- <m2o87q8wt2.fsf@gmail.com>
- In-Reply-To
- <kl6la6jb1dk3.fsf@chooglen-macbookpro.roam.corp.google.com>
Glen Choo <chooglen@google.com> writes:
Show 16 quoted lines
>> This series builds upon the previous conversion work on 'submodule update' and >> moves out all of that shell logic in 'git-submodule.sh' into >> 'builtin/submodule--helper.c'. > > Hey Atharva! I'm working on a series that will teach "git branch" how to > handle "--recurse-submodules". I plan to do this in-process because I > think this will take less overall effort than using child processes, and > to make it happen, I'm planning to add a helper function like > "for_each_submodule()", which would call a C callback function on each > submodule. > > This is conceptually similar to "git submodule foreach" and > for_each_listed_submodule() (though not exactly equivalent), so I'm > reaching out to you in case this work is already on your radar. If so, > and if it is coming soon, it might be easier to for me to base my work > off yours instead of duplicating our efforts :)
Thanks for reaching out. I don't have anything like this on my radar, so feel free to go ahead with your plan :)