Re: [PATCH 02/13] submodule--helper: get remote names from any repository
- From
Ævar Arnfjörð Bjarmason <avarab@gmail.com>
- Date
- Sep 7, 2021, 12:37 UTC
- Message-ID
- <871r60muge.fsf@evledraar.gmail.com>
- In-Reply-To
- <20210907115932.36068-3-raykar.ath@gmail.com>
On Tue, Sep 07 2021, Atharva Raykar wrote:
Show 12 quoted lines
> `get_default_remote()` retrieves the name of a remote by resolving the > refs from of the current repository's ref store. > > Thus in order to use it for retrieving the remote name of a submodule, > we have to start a new subprocess which runs from the submodule > directory. > > Let's instead introduce a function called `repo_get_default_remote()` > which takes any repository object and retrieves the remote accordingly. > > `get_default_remote()` is then defined as a call to > `repo_get_default_remote()` with 'the_repository' passed to it.
I'd find this easier to follow if this were just squashed into the next commit. Both are rather small, but following the context of first adding a function, then using it, instead of just adding it, changing the old users etc. is harder than just having it in one commit.