git/list[1] front-page[2] threads[3] people[4] search[5] about
 

[PATCH 0/8] Better heuristics make prettier diffs

From
Michael Haggerty <mhagger@alum.mit.edu>
Date
Aug 3, 2016, 22:00 UTC
Message-ID
<cover.1470259583.git.mhagger@alum.mit.edu>

I've talked about this quite a bit on the list already. The idea is to improve ugly diffs like

    @@ -231,6 +231,9 @@ if (!defined $initial_reply_to && $prompting) {
     }
     if (!$smtp_server) {
    +       $smtp_server = $repo->config('sendemail.smtpserver');
    +}
    +if (!$smtp_server) {
            foreach (qw( /usr/sbin/sendmail /usr/lib/sendmail )) {
                    if (-x $_) {
                            $smtp_server = $_;

by feeding clues from the surrounding lines (namely their patterns of indentation and blank lines) into a heuristic that more often produces the diffs that users would rather see, like

    --- a/9c572b21dd090a1e5c5bb397053bf8043ffe7fb4:git-send-email.perl
    +++ b/6dcfa306f2b67b733a7eb2d7ded1bc9987809edb:git-send-email.perl
    @@ -230,6 +230,9 @@ if (!defined $initial_reply_to && $prompting) {
            $initial_reply_to =~ s/(^\s+|\s+$)//g;
     }
    +if (!$smtp_server) {
    +       $smtp_server = $repo->config('sendemail.smtpserver');
    +}
     if (!$smtp_server) {
            foreach (qw( /usr/sbin/sendmail /usr/lib/sendmail )) {
                    if (-x $_) {

See the last commit's log message for a very detailed explanation of the heuristic, how it was optimized, and how you can get involved to make sure that the heuristic also works well for your favorite language.

When tested against a corpus of 2700 diffs that I optimized by hand, this heuristic gets a "wrong" answer only about 1.7% as frequently as the current default Git algorithm and only about 5.3% as often as `git diff --compaction-heuristic`. (Though please don't treat these numbers as final; I want to verify them again first.)

For now the new algorithm has to be enabled explicitly using either `--indent-heuristic` or `git config diff.indentheuristic true`.

Michael Haggerty (8):
  xdl_change_compact(): rename some local variables for clarity
  xdl_change_compact(): clarify code
  xdl_change_compact(): rename i to end
  xdl_change_compact(): do one final shift or the other, not both
  xdl_change_compact(): fix compaction heuristic to adjust io
  xdl_change_compact(): keep track of the earliest end
  is_blank_line: take a single xrecord_t as argument
  diff: improve positioning of add/delete blocks in diffs
 Documentation/diff-options.txt |   6 +-
 diff.c                         |  11 +
 git-add--interactive.perl      |   5 +-
 xdiff/xdiff.h                  |   1 +
 xdiff/xdiffi.c                 | 458 ++++++++++++++++++++++++++++++++++-------
 5 files changed, 409 insertions(+), 72 deletions(-)
-- 
2.8.1
Next: Michael Haggerty
Message 1 of 57 in “Better heuristics make prettier diffs”
  1. 0/8 Better heuristics make prettier diffsMichael Haggerty, Aug 3, 2016
  2. 2/8 xdl_change_compact(): clarify codeMichael Haggerty, Aug 3, 2016
  3. Stefan BellerAug 3, 2016
  4. Michael HaggertyAug 3, 2016
  5. Stefan BellerAug 3, 2016
  6. Jeff KingAug 4, 2016
  7. Michael HaggertyAug 10, 2016
  8. Stefan BellerAug 10, 2016
  9. 5/8 xdl_change_compact(): fix compaction heuristic to adjust ioMichael Haggerty, Aug 3, 2016
  10. Jeff KingAug 4, 2016
  11. Michael HaggertyAug 10, 2016
  12. Michael HaggertyAug 10, 2016
  13. Jeff KingAug 11, 2016
  14. Junio C HamanoAug 4, 2016
  15. Michael HaggertyAug 10, 2016
  16. 7/8 is_blank_line: take a single xrecord_t as argumentMichael Haggerty, Aug 3, 2016
  17. Junio C HamanoAug 4, 2016
  18. 6/8 xdl_change_compact(): keep track of the earliest endMichael Haggerty, Aug 3, 2016
  19. Junio C HamanoAug 4, 2016
  20. Michael HaggertyAug 10, 2016
  21. 4/8 xdl_change_compact(): do one final shift or the other, not bothMichael Haggerty, Aug 3, 2016
  22. 1/8 xdl_change_compact(): rename some local variables for clarityMichael Haggerty, Aug 3, 2016
  23. Jeff KingAug 4, 2016
  24. Junio C HamanoAug 4, 2016
  25. Michael HaggertyAug 13, 2016
  26. Jeff KingAug 14, 2016
  27. Michael HaggertyAug 3, 2016
  28. 3/8 xdl_change_compact(): rename i to endMichael Haggerty, Aug 3, 2016
  29. Jeff KingAug 4, 2016
  30. 8/8 diff: improve positioning of add/delete blocks in diffsMichael Haggerty, Aug 3, 2016
  31. Jacob KellerAug 3, 2016
  32. Michael HaggertyAug 3, 2016
  33. Jacob KellerAug 4, 2016
  34. Junio C HamanoAug 4, 2016
  35. Michael HaggertyAug 10, 2016
  36. Junio C HamanoAug 10, 2016
  37. Stefan BellerAug 3, 2016
  38. Michael HaggertyAug 3, 2016
  39. Stefan BellerAug 3, 2016
  40. Michael HaggertyAug 3, 2016
  41. Stefan BellerAug 4, 2016
  42. Michael HaggertyAug 10, 2016
  43. Jeff KingAug 4, 2016
  44. Stefan BellerAug 4, 2016
  45. Junio C HamanoAug 4, 2016
  46. Michael HaggertyAug 13, 2016
  47. Michael HaggertyAug 12, 2016
  48. Jeff KingAug 13, 2016
  49. Junio C HamanoAug 13, 2016
  50. Jacob KellerAug 14, 2016
  51. Stefan BellerAug 15, 2016
  52. Junio C HamanoAug 15, 2016
  53. Junio C HamanoAug 4, 2016
  54. Michael HaggertyAug 13, 2016
  55. Jeff KingAug 4, 2016
  56. Junio C HamanoAug 4, 2016
  57. Jeff KingAug 4, 2016

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.