Re: [PATCH 3/8] xdl_change_compact(): rename i to end
- From
Jeff King <peff@peff.net>
- Date
- Aug 4, 2016, 07:16 UTC
- Message-ID
- <20160804071608.p4uo46ye4uztkaz6@sigill.intra.peff.net>
- In-Reply-To
- <625e39916051e2ea5e09e1c0d3c4f6c25e61302d.1470259583.git.mhagger@alum.mit.edu>
On Thu, Aug 04, 2016 at 12:00:31AM +0200, Michael Haggerty wrote:
Show 6 quoted lines
> Rename i to end, and alternate between using start and end as the > indexing variable as appropriate. > > Rename ixref to end_matching_other. > > Add some more comments.
I'd usually complain that there is too much "what" in your commit message, but in this case, the diff really is hard to read. Having a summary up front is nice.
There's no "why", but I imagine it is just "I had to do this to even make sense of this function".
-Peff