git/list[1] front-page[2] threads[3] people[4] search[5] about
 

[PATCH 0/3] run-command.h: rename "env_array" to "env"

From
Ævar Arnfjörð Bjarmason <avarab@gmail.com>
Date
Apr 6, 2022, 10:42 UTC
Message-ID
<cover-0.3-00000000000-20220406T104134Z-avarab@gmail.com>
In-Reply-To
<Ybtb6Shdj56ACdub@coredump.intra.peff.net>
On Thu, Dec 16 2021, Jeff King wrote:
Show 11 quoted lines
> On Thu, Dec 16, 2021 at 12:51:55PM +0100, Ævar Arnfjörð Bjarmason wrote:
>
>> Or maybe you're not interested in either case, which is also fine. It's
>> really not needed for anything other than to resolve the minor oddity
>> that we have two "struct strvec"'s, "args" and "env_array". It's just a
>> bit odd to have one with "_array" in the name, which is only because the
>> now-removed "env" was taken at the time.
>
> Yeah, FWIW I absolutely hated "env_array" when I added it, but didn't
> want to do the transition all at once, so needed another name. So I
> would be happy to see it become "env" now. ;)

Perhaps this follow-up to 832ec72c3e1 (Merge branch 'ab/run-command', 2021-12-15) will warm Jeff's heart if/when he returns from his git sabbatical :)

Junio: We're in the RC period, but perhaps this change if we're ever
going to make it would be good to make around that time of patch
slowdown. I.e. for the first batch after release.

I've been holding onto this since around December, but when I checked there was always 1-2 series that was adding new use of "env_array", resolving that conflict didn't seem worth the hassle.

Right now this doesn't conflict with anything in "seen". The scary-at-first diffstat is almost entirely in 2/3, and everything except a two-line change in that commit is made by the coccinelle rule added in 1/3.

So this series for reviewing is really:
 * A trivial coccinelle rule in 1/3
 * The trivial 2 line change in run-command.h in 2/3 that isn't made
   by that rule
 * Subsequent trivial cleanup in 3/3 changing s/env_array/env/g in
   comments & variable names
Ævar Arnfjörð Bjarmason (3):
  cocci: add a rename of "struct child_process"'s "env_array" to "env"
  run-command API: rename "env_array" to "env"
  run-command API users: use "env" not "env_array" in comments & names
 add-patch.c                          |  2 +-
 branch.c                             |  2 +-
 builtin/difftool.c                   |  6 ++--
 builtin/receive-pack.c               | 32 ++++++++++----------
 builtin/stash.c                      | 16 +++++-----
 builtin/submodule--helper.c          | 44 ++++++++++++++--------------
 builtin/worktree.c                   |  8 ++---
 connect.c                            |  9 +++---
 connected.c                          |  2 +-
 contrib/coccinelle/run_command.cocci | 11 +++++++
 daemon.c                             | 14 ++++-----
 editor.c                             |  2 +-
 hook.c                               |  2 +-
 http-backend.c                       |  4 +--
 object-file.c                        |  2 +-
 pager.c                              |  4 +--
 promisor-remote.c                    |  2 +-
 run-command.c                        | 19 ++++++------
 run-command.h                        | 14 ++++-----
 sequencer.c                          | 18 ++++++------
 submodule.c                          | 38 ++++++++++++------------
 submodule.h                          |  4 +--
 t/helper/test-run-command.c          |  2 +-
 trailer.c                            |  2 +-
 transport-helper.c                   |  2 +-
 wt-status.c                          |  2 +-
 26 files changed, 138 insertions(+), 125 deletions(-)
 create mode 100644 contrib/coccinelle/run_command.cocci
-- 
2.36.0.rc0.849.g2d5b5d9ab01
Previous: Junio C HamanoNext: Ævar Arnfjörð Bjarmason
Message 6 of 26 in “What's cooking in git.git (Dec 2021, #04; Wed, 15)”
  1. Junio C HamanoDec 16, 2021
  2. ab/run-command (was: What's cooking in git.git (Dec 2021, #04; Wed, 15))Ævar Arnfjörð Bjarmason, Dec 16, 2021
  3. Jeff KingDec 16, 2021
  4. Ævar Arnfjörð BjarmasonDec 16, 2021
  5. Junio C HamanoDec 16, 2021
  6. 0/3 run-command.h: rename "env_array" to "env"Ævar Arnfjörð Bjarmason, Apr 6, 2022
  7. 1/3 cocci: add a rename of "struct child_process"'s "env_array" to "env"Ævar Arnfjörð Bjarmason, Apr 6, 2022
  8. 2/3 run-command API: rename "env_array" to "env"Ævar Arnfjörð Bjarmason, Apr 6, 2022
  9. 3/3 run-command API users: use "env" not "env_array" in comments & namesÆvar Arnfjörð Bjarmason, Apr 6, 2022
  10. Johannes SchindelinApr 7, 2022
  11. Junio C HamanoApr 7, 2022
  12. Junio C HamanoApr 7, 2022
  13. 0/4 run-command.h: rename "env_array" to "env"Ævar Arnfjörð Bjarmason, May 20, 2022
  14. 1/4 cocci: add a rename of "struct child_process"'s "env_array" to "env"Ævar Arnfjörð Bjarmason, May 20, 2022
  15. 3/4 cocci: remove env_array -> env migrationÆvar Arnfjörð Bjarmason, May 20, 2022
  16. 4/4 run-command API users: use "env" not "env_array" in comments & namesÆvar Arnfjörð Bjarmason, May 20, 2022
  17. 2/4 run-command API: rename "env_array" to "env"Ævar Arnfjörð Bjarmason, May 20, 2022
  18. Junio C HamanoMay 20, 2022
  19. Ævar Arnfjörð BjarmasonMay 21, 2022
  20. 0/2 run-command.h: rename "env_array" to "env"Ævar Arnfjörð Bjarmason, Jun 2, 2022
  21. 2/2 run-command API users: use "env" not "env_array" in comments & namesÆvar Arnfjörð Bjarmason, Jun 2, 2022
  22. 1/2 run-command API: rename "env_array" to "env"Ævar Arnfjörð Bjarmason, Jun 2, 2022
  23. Junio C HamanoJun 3, 2022
  24. ab/make-dependency (was: What's cooking in git.git (Dec 2021, #04; Wed, 15))Ævar Arnfjörð Bjarmason, Dec 16, 2021
  25. Aleen 徐沛文Dec 21, 2021
  26. Christian CouderDec 21, 2021

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.