git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH v2 0/4] run-command.h: rename "env_array" to "env"

From
Ævar Arnfjörð Bjarmason <avarab@gmail.com>
Date
May 21, 2022, 11:09 UTC
Message-ID
<220521.86czg716mb.gmgdl@evledraar.gmail.com>
In-Reply-To
<xmqqilq0jhk2.fsf@gitster.g>
On Fri, May 20 2022, Junio C Hamano wrote:
Show 28 quoted lines
> Ævar Arnfjörð Bjarmason  <avarab@gmail.com> writes:
>
>> Follow-up 32ec72c3e1 (Merge branch 'ab/run-command', 2021-12-15) and
>> rename the "env_array" member to simply "env" in the "struct
>> child_process".
>>
>> Changes since v1:
>>
>>  * Added a commit to remove the coccinelle rule after its application,
>>    as suggested by Junio in
>>    https://lore.kernel.org/git/xmqqzgjdkxon.fsf@gitster.g/
>
> I actually think we do not even have to tentatively add one, only to
> remove it at the end.
>
> Wouldn't a two-patch series whose 
>
>  - first patch does the real damage to the codebase, with the
>    coccinelle rule as part of the commit explanation in the proposed
>    log message (e.g. "the patch was mechanically prepared with the
>    help with this Coccinelle semantic patch"), and
>
>  - the second patch does the non-mechanical "comments and names"
>
> work better than four patch series?  A single patch that says "the
> code was mechanically updated with this s-patch, with names and
> comments that refer to env_array in the surrounding code manually
> adjusted" would also work well.

I can re-roll it if you insist, but I think it's much more useful to have rules added to contrib/coccinelle, even if they're subsequently removed within the same series.

I've ofter paged through "git log -p -- contrib/coccinelle" to get inspiration from previous rules we used or see what's valid syntax. I think being able to do that consistently and not having to fish through log messages as well is more useful.

It also makes it easier for someone who needs to modify their code to just "git checkout" and run "spatch" on the rule, without copy/pasting from a log message.

But anyway, whatever you prefer. I see from the latest WC you're expecting a re-roll, maybe the above will convince you, and if not I can prepare a v3 with your suggested changes. Thanks.

Previous: Junio C HamanoNext: Ævar Arnfjörð Bjarmason
Message 19 of 26 in “What's cooking in git.git (Dec 2021, #04; Wed, 15)”
  1. Junio C HamanoDec 16, 2021
  2. ab/run-command (was: What's cooking in git.git (Dec 2021, #04; Wed, 15))Ævar Arnfjörð Bjarmason, Dec 16, 2021
  3. Jeff KingDec 16, 2021
  4. Ævar Arnfjörð BjarmasonDec 16, 2021
  5. Junio C HamanoDec 16, 2021
  6. 0/3 run-command.h: rename "env_array" to "env"Ævar Arnfjörð Bjarmason, Apr 6, 2022
  7. 1/3 cocci: add a rename of "struct child_process"'s "env_array" to "env"Ævar Arnfjörð Bjarmason, Apr 6, 2022
  8. 2/3 run-command API: rename "env_array" to "env"Ævar Arnfjörð Bjarmason, Apr 6, 2022
  9. 3/3 run-command API users: use "env" not "env_array" in comments & namesÆvar Arnfjörð Bjarmason, Apr 6, 2022
  10. Johannes SchindelinApr 7, 2022
  11. Junio C HamanoApr 7, 2022
  12. Junio C HamanoApr 7, 2022
  13. 0/4 run-command.h: rename "env_array" to "env"Ævar Arnfjörð Bjarmason, May 20, 2022
  14. 1/4 cocci: add a rename of "struct child_process"'s "env_array" to "env"Ævar Arnfjörð Bjarmason, May 20, 2022
  15. 3/4 cocci: remove env_array -> env migrationÆvar Arnfjörð Bjarmason, May 20, 2022
  16. 4/4 run-command API users: use "env" not "env_array" in comments & namesÆvar Arnfjörð Bjarmason, May 20, 2022
  17. 2/4 run-command API: rename "env_array" to "env"Ævar Arnfjörð Bjarmason, May 20, 2022
  18. Junio C HamanoMay 20, 2022
  19. Ævar Arnfjörð BjarmasonMay 21, 2022
  20. 0/2 run-command.h: rename "env_array" to "env"Ævar Arnfjörð Bjarmason, Jun 2, 2022
  21. 2/2 run-command API users: use "env" not "env_array" in comments & namesÆvar Arnfjörð Bjarmason, Jun 2, 2022
  22. 1/2 run-command API: rename "env_array" to "env"Ævar Arnfjörð Bjarmason, Jun 2, 2022
  23. Junio C HamanoJun 3, 2022
  24. ab/make-dependency (was: What's cooking in git.git (Dec 2021, #04; Wed, 15))Ævar Arnfjörð Bjarmason, Dec 16, 2021
  25. Aleen 徐沛文Dec 21, 2021
  26. Christian CouderDec 21, 2021

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.