git/list[1] front-page[2] threads[3] people[4] search[5] about
 

ab/make-dependency (was: What's cooking in git.git (Dec 2021, #04; Wed, 15))

From
Ævar Arnfjörð Bjarmason <avarab@gmail.com>
Date
Dec 16, 2021, 23:46 UTC
Message-ID
<211217.86a6h09km9.gmgdl@evledraar.gmail.com>
In-Reply-To
<xmqq8rwlz3cq.fsf@gitster.g>
On Wed, Dec 15 2021, Junio C Hamano wrote:
Show 32 quoted lines
> * ab/make-dependency (2021-11-18) 24 commits
>  - Makefile: move ".SUFFIXES" rule to shared.mak
>  - Makefile: define $(LIB_H) in terms of $(FIND_SOURCE_FILES)
>  - Makefile: disable GNU make built-in wildcard rules
>  - Makefile: use $(file) I/O instead of "FORCE" when possible
>  - Makefile: correct the dependency graph of hook-list.h
>  - Makefiles: add and use wildcard "mkdir -p" template
>  - Makefile: use $(wspfx) for $(QUIET...) in shared.mak
>  - Makefile: add "$(QUIET)" boilerplate to shared.mak
>  - Makefile: add a "TRACK_template" for GIT-*{FLAGS,DEFINES,...}
>  - Makefile: re-add and use the "shellquote" macros
>  - Makefile: move $(comma), $(empty) and $(space) to shared.mak
>  - Makefiles: add "shared.mak", move ".DELETE_ON_ERROR" to it
>  - Makefile: stop needing @@GIT_VERSION@@ in *.perl scripts
>  - Makefile: create a GIT-PYTHON-DEFINES, like "PERL"
>  - Makefile: correct "GIT-PERL-{DEFINES,HEADER}" dependency graph
>  - Makefile: adjust Perl-related comments & whitespace
>  - Makefile: change "ifndef NO_PERL" to "ifdef NO_PERL"
>  - Makefile: guard Perl-only variable assignments
>  - Makefile: remove "mv $@ $@+" dance redundant to .DELETE_ON_ERROR
>  - Makefile: clean perl/build/ even with NO_PERL=Y
>  - Makefile: use "=" not ":=" for po/* and perl/*
>  - Makefile: don't set up "perl/build" rules under NO_PERL=Y
>  - Makefile: don't invoke msgfmt with --statistics
>  - Merge branch 'ab/sh-retire-helper-functions' into ab/make-dependency
>
>  Dependency clean-up.
>
>  Needs review.
>  There are some comments on earlier rounds; the latest one needs a
>  serious review or at least Acks from past commentors.
>  source: <patch-v4-23.23-48a3927d972-20211117T101807Z-avarab@gmail.com>
I think it's best to drop this rather large topic for now.

I started re-rolling it with improvements to address your shell escaping comments, and ended up with a much better end-state, but it's now at north of 30 commits locally.

So I've split it up and have some incoming patches. Not for all of it, just starting with some of the more urgent than not fixes & more trivial & easy to review changes, or around 1/2 of what's quoted above.

I'll then submit the rest sometime after that lands.
Previous: Junio C HamanoNext: Aleen 徐沛文
Message 24 of 26 in “What's cooking in git.git (Dec 2021, #04; Wed, 15)”
  1. Junio C HamanoDec 16, 2021
  2. ab/run-command (was: What's cooking in git.git (Dec 2021, #04; Wed, 15))Ævar Arnfjörð Bjarmason, Dec 16, 2021
  3. Jeff KingDec 16, 2021
  4. Ævar Arnfjörð BjarmasonDec 16, 2021
  5. Junio C HamanoDec 16, 2021
  6. 0/3 run-command.h: rename "env_array" to "env"Ævar Arnfjörð Bjarmason, Apr 6, 2022
  7. 1/3 cocci: add a rename of "struct child_process"'s "env_array" to "env"Ævar Arnfjörð Bjarmason, Apr 6, 2022
  8. 2/3 run-command API: rename "env_array" to "env"Ævar Arnfjörð Bjarmason, Apr 6, 2022
  9. 3/3 run-command API users: use "env" not "env_array" in comments & namesÆvar Arnfjörð Bjarmason, Apr 6, 2022
  10. Johannes SchindelinApr 7, 2022
  11. Junio C HamanoApr 7, 2022
  12. Junio C HamanoApr 7, 2022
  13. 0/4 run-command.h: rename "env_array" to "env"Ævar Arnfjörð Bjarmason, May 20, 2022
  14. 1/4 cocci: add a rename of "struct child_process"'s "env_array" to "env"Ævar Arnfjörð Bjarmason, May 20, 2022
  15. 3/4 cocci: remove env_array -> env migrationÆvar Arnfjörð Bjarmason, May 20, 2022
  16. 4/4 run-command API users: use "env" not "env_array" in comments & namesÆvar Arnfjörð Bjarmason, May 20, 2022
  17. 2/4 run-command API: rename "env_array" to "env"Ævar Arnfjörð Bjarmason, May 20, 2022
  18. Junio C HamanoMay 20, 2022
  19. Ævar Arnfjörð BjarmasonMay 21, 2022
  20. 0/2 run-command.h: rename "env_array" to "env"Ævar Arnfjörð Bjarmason, Jun 2, 2022
  21. 2/2 run-command API users: use "env" not "env_array" in comments & namesÆvar Arnfjörð Bjarmason, Jun 2, 2022
  22. 1/2 run-command API: rename "env_array" to "env"Ævar Arnfjörð Bjarmason, Jun 2, 2022
  23. Junio C HamanoJun 3, 2022
  24. ab/make-dependency (was: What's cooking in git.git (Dec 2021, #04; Wed, 15))Ævar Arnfjörð Bjarmason, Dec 16, 2021
  25. Aleen 徐沛文Dec 21, 2021
  26. Christian CouderDec 21, 2021

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.