Re: [PATCH] Rename core.unreliableHardlinks to core.createObject
- From
Johannes Schindelin <johannes.schindelin@gmx.de>
- Date
- Apr 28, 2009, 14:50 UTC
- Message-ID
- <alpine.DEB.1.00.0904281647350.10279@pacific.mpi-cbg.de>
- In-Reply-To
- <7v1vrdqi9i.fsf@gitster.siamese.dyndns.org>
Hi,
On Tue, 28 Apr 2009, Junio C Hamano wrote:
Show 10 quoted lines
> Johannes Schindelin <Johannes.Schindelin@gmx.de> writes: > > >> With the configuration variable for this relatively obscure feature > >> in place, I wonder if we can simply get rid of the hardcoded > >> compilation preference. > > > > I'd rather not, for Windows. Remember, it fixes issues 222 and 229. > > Wait a bit. Wasn't this about you accessing NTFS on your EeePC via unfs > from the Linux side?
Both. I realized that there was a problem with the ufsd driver of the Xandros Linux on my EeePC, accessing NTFS partitions. (This is the issue that made me add a config variable, but which was solved by Linus' core.fsyncobjects suggestion.)
Later I had a hunch that the issues 222 and 229 of msysGit might have exactly the same reason, let the reporters test, and indeed, the problems went away.
But come to think of it, we can _easily_ just set core.createObject=rename in msysGit, so I agree that there is no longer a need for the Makefile variable.
Want me to resend?
Ciao, Dscho