Re: [PATCH] Rename core.unreliableHardlinks to core.createObject
- From
Johannes Schindelin <johannes.schindelin@gmx.de>
- Date
- Apr 28, 2009, 08:23 UTC
- Message-ID
- <alpine.DEB.1.00.0904281022070.10279@pacific.mpi-cbg.de>
- In-Reply-To
- <7vws95vete.fsf@gitster.siamese.dyndns.org>
Hi,
On Mon, 27 Apr 2009, Junio C Hamano wrote:
Show 18 quoted lines
> Johannes Schindelin <Johannes.Schindelin@gmx.de> writes: > > > diff --git a/Makefile b/Makefile > > index 5c8e83a..9ca1826 100644 > > --- a/Makefile > > +++ b/Makefile > > @@ -172,8 +172,8 @@ all:: > > # information on a not yet closed file that lstat would return for the same > > # file after it was closed. > > # > > -# Define UNRELIABLE_HARDLINKS if your operating systems has problems when > > -# hardlinking a file to another name and unlinking the original file right > > +# Define OBJECT_CREATION_USES_RENAMES if your operating systems has problems > > +# when hardlinking a file to another name and unlinking the original file right > > With the configuration variable for this relatively obscure feature in > place, I wonder if we can simply get rid of the hardcoded compilation > preference.
I'd rather not, for Windows. Remember, it fixes issues 222 and 229. And from the comments in those issues I understand that more than 2 persons had problems due to these issues.
Ciao, Dscho