From: Johannes Schindelin Date: Tue, 28 Apr 2009 14:50:01 GMT Subject: Re: [PATCH] Rename core.unreliableHardlinks to core.createObject Message-ID: In-Reply-To: <7v1vrdqi9i.fsf@gitster.siamese.dyndns.org> Hi, On Tue, 28 Apr 2009, Junio C Hamano wrote: > Johannes Schindelin writes: > > >> With the configuration variable for this relatively obscure feature > >> in place, I wonder if we can simply get rid of the hardcoded > >> compilation preference. > > > > I'd rather not, for Windows. Remember, it fixes issues 222 and 229. > > Wait a bit. Wasn't this about you accessing NTFS on your EeePC via unfs > from the Linux side? Both. I realized that there was a problem with the ufsd driver of the Xandros Linux on my EeePC, accessing NTFS partitions. (This is the issue that made me add a config variable, but which was solved by Linus' core.fsyncobjects suggestion.) Later I had a hunch that the issues 222 and 229 of msysGit might have exactly the same reason, let the reporters test, and indeed, the problems went away. But come to think of it, we can _easily_ just set core.createObject=rename in msysGit, so I agree that there is no longer a need for the Makefile variable. Want me to resend? Ciao, Dscho