Re: [PATCH v3 02/32] doc hash-function-transition: Augment compatObjectFormat with readCompatMap
- From
Oswald Buddenhagen <oswald.buddenhagen@gmx.de>
- Date
- Sep 13, 2023, 08:10 UTC
- Message-ID
- <ZQFukZ4q2Ehen8Yn@ugly>
- In-Reply-To
- <87msxr8uc1.fsf@email.froward.int.ebiederm.org>
On Tue, Sep 12, 2023 at 07:11:26AM -0500, Eric W. Biederman wrote:
Show 11 quoted lines
>Oswald Buddenhagen <oswald.buddenhagen@gmx.de> writes: >> On Mon, Sep 11, 2023 at 06:46:19PM -0500, Eric W. Biederman wrote: >>>+The difference between compatObjectFormat and readCompatMap would be that >>>+compatObjectFormat would ask git to read existing maps, but would not ask >>>+git to write or create them. >>> >> the argument makes sense, but the asymmetry in the naming bugs me. in particular >> "[read]compatMap" seems too non-descript. > >I am open to suggestions for better names. >
isn't readCompatObjectFormat an obvious choice? (and for symmetry, the other then would be writeCompatObjectFormat, i guess.)
regards