Re: [PATCH v3 02/32] doc hash-function-transition: Augment compatObjectFormat with readCompatMap
- From
Eric W. Biederman <ebiederm@xmission.com>
- Date
- Sep 12, 2023, 12:11 UTC
- Message-ID
- <87msxr8uc1.fsf@email.froward.int.ebiederm.org>
- In-Reply-To
- <ZQAZ19gyvt8ab7f6@ugly>
Oswald Buddenhagen <oswald.buddenhagen@gmx.de> writes:
Show 7 quoted lines
> On Mon, Sep 11, 2023 at 06:46:19PM -0500, Eric W. Biederman wrote: >>+The difference between compatObjectFormat and readCompatMap would be that >>+compatObjectFormat would ask git to read existing maps, but would not ask >>+git to write or create them. >> > the argument makes sense, but the asymmetry in the naming bugs me. in particular > "[read]compatMap" seems too non-descript.
I am open to suggestions for better names.
From a code point of view I am intending readCompatMap only supporting the things that can be support with just the mapping functions aka repo_oid_to_algop for the "readComatMap" case.
While the compatObjectFormat case includes what can be done with using the compatible hash algorithm and convert_object_file.
There is quite a large variation. So there is some fundamental asymmetry in the implementation. I am just not certain how to name it.
Eric