Re: [PATCH v2 3/3] difftool: eliminate use of USE_THE_REPOSITORY_VARIABLE
- From
Patrick Steinhardt <ps@pks.im>
- Date
- Feb 7, 2025, 06:28 UTC
- Message-ID
- <Z6WoEjEo9Seffm_q@pks.im>
- In-Reply-To
- <CABPp-BGi51EQvPOgaz8p0RjAJ0zDDeTpMDp__puz_wQH5wowXw@mail.gmail.com>
On Thu, Feb 06, 2025 at 12:31:14AM -0800, Elijah Newren wrote:
Show 28 quoted lines
> On Wed, Feb 5, 2025 at 8:20 PM David Aguilar <davvid@gmail.com> wrote: > > > > Remove the USE_THE_REPOSITORY_VARIABLE #define now that all > > state is passed to each function from callers. > > > > Signed-off-by: David Aguilar <davvid@gmail.com> > > --- > > builtin/difftool.c | 2 -- > > 1 file changed, 2 deletions(-) > > > > diff --git a/builtin/difftool.c b/builtin/difftool.c > > index 81d733dfdf..41cd00066c 100644 > > --- a/builtin/difftool.c > > +++ b/builtin/difftool.c > > @@ -12,8 +12,6 @@ > > * Copyright (C) 2016 Johannes Schindelin > > */ > > > > -#define USE_THE_REPOSITORY_VARIABLE > > - > > #include "builtin.h" > > > > #include "abspath.h" > > -- > > 2.48.1.461.g612e419e04 > > > Nice; thanks for working on this.
Yup, thanks for rerolling. This version is much easier to read indeed and looks good to me.
Patrick