Re: [PATCH v7 2/3] maintenance: `git maintenance run` learned `--scheduler=<scheduler>`
- From
Jeff King <peff@peff.net>
- Date
- Jul 13, 2021, 03:56 UTC
- Message-ID
- <YO0O9JHtnYrk9qRm@coredump.intra.peff.net>
- In-Reply-To
- <CAPig+cT-x4_YuxmmoFw62jFqKRFJrS_UkyNOkdQz9-Gwec3QCQ@mail.gmail.com>
On Mon, Jul 12, 2021 at 10:22:22PM -0400, Eric Sunshine wrote:
Show 18 quoted lines
> On Mon, Jul 12, 2021 at 8:16 PM Jeff King <peff@peff.net> wrote: > > On Tue, Jul 06, 2021 at 01:52:12PM -0700, Junio C Hamano wrote: > > > A helper function that takes a string and returns a strvec would be > > > a good fit, though. > > > > I was going to second that, but I see we already have one. :) Dscho > > introduced it in c5aa6db64f (argv_array: offer to split a string by > > whitespace, 2018-04-25), and then it later became strvec_split(). > > > > And indeed, Lénaïc's patches use it elsewhere. I think it doesn't work > > in this instance because it can't take an arbitrary delimiter. But I > > wouldn't at all mind seeing it grow that feature (and I suspect it could > > even share some code with string_list_split(), but didn't look). > > Since Lénaïc is a relative newcomer to the project, can we, as > reviewers, be clear that we don't expect him to perform the task of > generalizing strvec_split() just to get this series -- which is > already at v7 -- landed?
Yeah, sorry if I was unclear on that. That is absolutely not a requirement for this series.
(I do not have an opinion on Ævar's original question about using a split function rather than open-coding. _If_ we were to do that, string_list_split() would be the sensible existing mechanism. But it is also not worth derailing the series for).
-Peff