Re: What's cooking in git.git (Dec 2020, #01; Tue, 8)
- From
Taylor Blau <me@ttaylorr.com>
- Date
- Dec 9, 2020, 23:02 UTC
- Message-ID
- <X9FXnWLFT/2v8acE@nand.local>
- In-Reply-To
- <xmqqy2i738x1.fsf@gitster.c.googlers.com>
On Tue, Dec 08, 2020 at 08:22:50PM -0800, Junio C Hamano wrote:
Show 16 quoted lines
> Elijah Newren <newren@gmail.com> writes: > > > On Tue, Dec 8, 2020 at 5:37 PM Junio C Hamano <gitster@pobox.com> wrote: > >> > >> * en/diffcore-rename (2020-12-07) 5 commits > >> - diffcore-rename: simplify and accelerate register_rename_src() > >> - diffcore-rename: reduce jumpiness in progress counters > >> - diffcore-rename: rename num_create to num_targets > >> - diffcore-rename: remove unnecessary if-clause > >> - diffcore-rename: avoid usage of global in too_many_rename_candidates() > > > > Curious. I submitted 7 patches for this series. > > Yeah, I wanted to leave the "hard-to-digest" one out, and queued the > "relatively easy to review" ones. Even then, I ran out of time to > read these early 6 (and nobody else seems to have done so, either).
I reviewed all seven, and would be happy to see these merged up. The first five were all pretty trivial to review, and the last two definitely required more attention, but I couldn't spot any correctness issues with them.
It might not hurt to get another set of eyes on 6/7 and 7/7, so if you just want to take the first 1-5/7 for now, that'd be fine with me, too.
Thanks, Taylor