git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH v2 16/22] git-remote-mediawiki: Modify strings for a better coding-style

From
Eric Sunshine <sunshine@sunshineco.com>
Date
Jun 9, 2013, 04:44 UTC
Message-ID
<CAPig+cT5YQb9ZTX=x0bSv6Y=stWpR77wKt0xt-CuFhMidc3Ocw@mail.gmail.com>
In-Reply-To
<51B394E5.8040104@ensimag.fr>

On Sat, Jun 8, 2013 at 4:32 PM, Célestin Matte <celestin.matte@ensimag.fr> wrote:

Show 15 quoted lines
> Le 08/06/2013 02:39, Eric Sunshine a écrit :
>> On Fri, Jun 7, 2013 at 5:42 PM, Célestin Matte
>> <celestin.matte@ensimag.fr> wrote:
>>> - strings which don't need interpolation are single-quoted for more clarity and
>>> slight gain of performance
>>> - interpolation is preferred over concatenation in many cases, for more clarity
>>> - variables are always used with the ${} operator inside strings
>>> - strings including double-quotes are written with qq() so that the quotes do
>>> not have to be escaped
>>
>> Distinct changes could (IMHO) be split into separate patches for easier review.
>
> This commit is a real pain to cut into 3 distinctive ones. Is this
> really necessary?
> I will do it if it is, of course.
[I think you meant that it would be split into 4 patches.]

The final decision is up to the submitter (you) and the people signing off on and accepting the patch (Matthieu and Junio).

Speaking merely as a person reviewing the patch series, I can say that mixing conceptually unrelated changes into a single patch makes review more onerous since it requires repeatedly switching mental gears (often from line to line or even within a single line). Patches involving simple "mechanical" changes typically are easy to review, even when the patches are lengthy. In this case, however, that length coupled with the mental gear switching, makes the review process more burdensome that it need be.

Even if you decide ultimately not to bother splitting the patch, ease-of-review and one-conceptual-change-per-patch are useful notions to keep in mind for future submissions.

Previous: Célestin MatteNext: Célestin Matte
Message 33 of 41 in “git-remote-mediawiki: Follow perlcritic's recommandations”
  1. 00/22 git-remote-mediawiki: Follow perlcritic's recommandationsCélestin Matte, Jun 7, 2013
  2. 01/22 git-remote-mediawiki: Replace :utf8 by :encoding(UTF-8)Célestin Matte, Jun 7, 2013
  3. 02/22 git-remote-mediawiki: Use the Readonly module instead of the constant pragmaCélestin Matte, Jun 7, 2013
  4. Jeff KingJun 8, 2013
  5. Benoît PersonJun 8, 2013
  6. Célestin PerduJun 8, 2013
  7. Jeff KingJun 8, 2013
  8. Matthieu MoyJun 8, 2013
  9. 03/22 git-remote-mediawiki: Always end a subroutine with a returnCélestin Matte, Jun 7, 2013
  10. 04/22 git-remote-mediawiki: Move a variable declaration at the top of the codeCélestin Matte, Jun 7, 2013
  11. 05/22 git-remote-mediawiki: Change syntax of map callsCélestin Matte, Jun 7, 2013
  12. 06/22 git-remote-mediawiki: Rewrite unclear line of instructionsCélestin Matte, Jun 7, 2013
  13. 07/22 git-remote-mediawiki: Change style of some regular expressionsCélestin Matte, Jun 7, 2013
  14. Eric SunshineJun 8, 2013
  15. 08/22 git-remote-mediawiki: Add newline in the end of die() error messagesCélestin Matte, Jun 7, 2013
  16. 09/22 git-remote-mediawiki: Change the name of a variableCélestin Matte, Jun 7, 2013
  17. 10/22 git-remote-mediawiki: Turn double-negated expressions into simple expressionsCélestin Matte, Jun 7, 2013
  18. 11/22 git-remote-mediawiki: Remove unused variable $entryCélestin Matte, Jun 7, 2013
  19. 12/22 git-remote-mediawiki: Rename a variable ($last) which has the name of a keywordCélestin Matte, Jun 7, 2013
  20. 13/22 git-remote-mediawiki: Assign a variable as undef and make proper indentationCélestin Matte, Jun 7, 2013
  21. 14/22 git-remote-mediawiki: Check return value of open + remove import of unused open2Célestin Matte, Jun 7, 2013
  22. Eric SunshineJun 8, 2013
  23. Célestin MatteJun 8, 2013
  24. Matthieu MoyJun 8, 2013
  25. Célestin MatteJun 8, 2013
  26. Matthieu MoyJun 8, 2013
  27. Eric SunshineJun 9, 2013
  28. 15/22 git-remote-mediawiki: Put long code into a subroutineCélestin Matte, Jun 7, 2013
  29. Eric SunshineJun 8, 2013
  30. 16/22 git-remote-mediawiki: Modify strings for a better coding-styleCélestin Matte, Jun 7, 2013
  31. Eric SunshineJun 8, 2013
  32. Célestin MatteJun 8, 2013
  33. Eric SunshineJun 9, 2013
  34. 17/22 git-remote-mediawiki: Brace file handles for print for more clarityCélestin Matte, Jun 7, 2013
  35. Eric SunshineJun 8, 2013
  36. 18/22 git-remote-mediawiki: Replace "unless" statements with negated "if" statementsCélestin Matte, Jun 7, 2013
  37. 19/22 git-remote-mediawiki: Don't use quotes for empty stringsCélestin Matte, Jun 7, 2013
  38. 20/22 git-remote-mediawiki: Put non-trivial numeric values in constants.Célestin Matte, Jun 7, 2013
  39. 21/22 git-remote-mediawiki: Fix a typo ("mediwiki" instead of "mediawiki")Célestin Matte, Jun 7, 2013
  40. 22/22 git-remote-mediawiki: Clearly rewrite double dereferenceCélestin Matte, Jun 7, 2013
  41. Eric SunshineJun 7, 2013

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.