v2 of patch to follow perlcritic's recommandations ([1])
Changes with v1:
- split first commit into 6 different commits
- remove commit [17/18] about moving open() call
- took every other comment into account
[1]: http://thread.gmane.org/gmane.comp.version-control.git/226533
Célestin Matte (22):
git-remote-mediawiki: Replace :utf8 by :encoding(UTF-8)
git-remote-mediawiki: Use the Readonly module instead of the constant
pragma
git-remote-mediawiki: Always end a subroutine with a return
git-remote-mediawiki: Move a variable declaration at the top of the
code
git-remote-mediawiki: Change syntax of map calls
git-remote-mediawiki: Rewrite unclear line of instructions
git-remote-mediawiki: Change style of some regular expressions
git-remote-mediawiki: Add newline in the end of die() error messages
git-remote-mediawiki: Change the name of a variable
git-remote-mediawiki: Turn double-negated expressions into simple
expressions
git-remote-mediawiki: Remove unused variable $entry
git-remote-mediawiki: Rename a variable ($last) which has the name of
a keyword
git-remote-mediawiki: Assign a variable as undef and make proper
indentation
git-remote-mediawiki: Check return value of open + remove import of
unused open2
git-remote-mediawiki: Put long code into a subroutine
git-remote-mediawiki: Modify strings for a better coding-style
git-remote-mediawiki: Brace file handles for print for more clarity
git-remote-mediawiki: Replace "unless" statements with negated "if"
statements
git-remote-mediawiki: Don't use quotes for empty strings
git-remote-mediawiki: Put non-trivial numeric values in constants.
git-remote-mediawiki: Fix a typo ("mediwiki" instead of "mediawiki")
git-remote-mediawiki: Clearly rewrite double dereference contrib/mw-to-git/git-remote-mediawiki.perl | 545 ++++++++++++++-------------
1 file changed, 293 insertions(+), 252 deletions(-)