git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH v2 02/22] git-remote-mediawiki: Use the Readonly module instead of the constant pragma

From
BPBenoît Person <benoit.person@ensimag.fr>
Date
Jun 8, 2013, 08:51 UTC
Message-ID
<CAETqRCia1CqkaaHCFk=7mxVgmuN1VhBbGVs_oEaObUxwHZ33Zw@mail.gmail.com>
In-Reply-To
<20130608032324.GA20226@sigill.intra.peff.net>

The major drawback of using perl `constant` is the fact that they do not interpolate like variables in most of the contexts (those who automatically quotes barewords). Like said on Perl Monks here [1], you have to do some "tricks" depending on the context in which you're using the constant and that's not really "clean".

But maybe trading clean for another package is not worth it. I just searched for alternatives way of doing it and none seems to be in the core packages so maybe we should just drop this.

[1] http://www.perlmonks.org/?node_id=777711
On 8 June 2013 05:23, Jeff King <peff@peff.net> wrote:
Show 29 quoted lines
> On Fri, Jun 07, 2013 at 11:42:03PM +0200, Célestin Matte wrote:
>
>> diff --git a/contrib/mw-to-git/git-remote-mediawiki.perl b/contrib/mw-to-git/git-remote-mediawiki.perl
>> index 4893442..e60793a 100755
>> --- a/contrib/mw-to-git/git-remote-mediawiki.perl
>> +++ b/contrib/mw-to-git/git-remote-mediawiki.perl
>> @@ -26,21 +26,21 @@ use IPC::Open2;
>>  use Readonly;
>
> What does this series apply on top of? The existing version in "master"
> does not have "use Readonly" in it at all. The first version of your
> series introduced that line, but here it is shown as an existing line.
> Did you miss a commit when putting your patches together?
>
>>  # Mediawiki filenames can contain forward slashes. This variable decides by which pattern they should be replaced
>> -use constant SLASH_REPLACEMENT => "%2F";
>> +Readonly my $SLASH_REPLACEMENT => "%2F";
>
> What advantage does this have over "use constant"? I do not mind
> following guidelines from perlcritic if they are a matter of style, but
> in this case there is a cost: we now depend on the "Readonly" module,
> which is not part of the standard distribution. I.e., users now have to
> deal with installing an extra dependency. Is it worth it?
>
> -Peff
> --
> To unsubscribe from this list: send the line "unsubscribe git" in
> the body of a message to majordomo@vger.kernel.org
> More majordomo info at  http://vger.kernel.org/majordomo-info.html
Previous: Jeff KingNext: Célestin Perdu
Message 5 of 41 in “git-remote-mediawiki: Follow perlcritic's recommandations”
  1. 00/22 git-remote-mediawiki: Follow perlcritic's recommandationsCélestin Matte, Jun 7, 2013
  2. 01/22 git-remote-mediawiki: Replace :utf8 by :encoding(UTF-8)Célestin Matte, Jun 7, 2013
  3. 02/22 git-remote-mediawiki: Use the Readonly module instead of the constant pragmaCélestin Matte, Jun 7, 2013
  4. Jeff KingJun 8, 2013
  5. Benoît PersonJun 8, 2013
  6. Célestin PerduJun 8, 2013
  7. Jeff KingJun 8, 2013
  8. Matthieu MoyJun 8, 2013
  9. 03/22 git-remote-mediawiki: Always end a subroutine with a returnCélestin Matte, Jun 7, 2013
  10. 04/22 git-remote-mediawiki: Move a variable declaration at the top of the codeCélestin Matte, Jun 7, 2013
  11. 05/22 git-remote-mediawiki: Change syntax of map callsCélestin Matte, Jun 7, 2013
  12. 06/22 git-remote-mediawiki: Rewrite unclear line of instructionsCélestin Matte, Jun 7, 2013
  13. 07/22 git-remote-mediawiki: Change style of some regular expressionsCélestin Matte, Jun 7, 2013
  14. Eric SunshineJun 8, 2013
  15. 08/22 git-remote-mediawiki: Add newline in the end of die() error messagesCélestin Matte, Jun 7, 2013
  16. 09/22 git-remote-mediawiki: Change the name of a variableCélestin Matte, Jun 7, 2013
  17. 10/22 git-remote-mediawiki: Turn double-negated expressions into simple expressionsCélestin Matte, Jun 7, 2013
  18. 11/22 git-remote-mediawiki: Remove unused variable $entryCélestin Matte, Jun 7, 2013
  19. 12/22 git-remote-mediawiki: Rename a variable ($last) which has the name of a keywordCélestin Matte, Jun 7, 2013
  20. 13/22 git-remote-mediawiki: Assign a variable as undef and make proper indentationCélestin Matte, Jun 7, 2013
  21. 14/22 git-remote-mediawiki: Check return value of open + remove import of unused open2Célestin Matte, Jun 7, 2013
  22. Eric SunshineJun 8, 2013
  23. Célestin MatteJun 8, 2013
  24. Matthieu MoyJun 8, 2013
  25. Célestin MatteJun 8, 2013
  26. Matthieu MoyJun 8, 2013
  27. Eric SunshineJun 9, 2013
  28. 15/22 git-remote-mediawiki: Put long code into a subroutineCélestin Matte, Jun 7, 2013
  29. Eric SunshineJun 8, 2013
  30. 16/22 git-remote-mediawiki: Modify strings for a better coding-styleCélestin Matte, Jun 7, 2013
  31. Eric SunshineJun 8, 2013
  32. Célestin MatteJun 8, 2013
  33. Eric SunshineJun 9, 2013
  34. 17/22 git-remote-mediawiki: Brace file handles for print for more clarityCélestin Matte, Jun 7, 2013
  35. Eric SunshineJun 8, 2013
  36. 18/22 git-remote-mediawiki: Replace "unless" statements with negated "if" statementsCélestin Matte, Jun 7, 2013
  37. 19/22 git-remote-mediawiki: Don't use quotes for empty stringsCélestin Matte, Jun 7, 2013
  38. 20/22 git-remote-mediawiki: Put non-trivial numeric values in constants.Célestin Matte, Jun 7, 2013
  39. 21/22 git-remote-mediawiki: Fix a typo ("mediwiki" instead of "mediawiki")Célestin Matte, Jun 7, 2013
  40. 22/22 git-remote-mediawiki: Clearly rewrite double dereferenceCélestin Matte, Jun 7, 2013
  41. Eric SunshineJun 7, 2013

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.