git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH v4 05/12] ref-filter: introduce parsing functions for each valid atom

From
Eric Sunshine <sunshine@sunshineco.com>
Date
Feb 3, 2016, 22:19 UTC
Message-ID
<CAPig+cRmfNjP8PYoQFZ7YrECgt03aE1=QynG58-+cd9ORJneZw@mail.gmail.com>
In-Reply-To
<1454262176-6594-6-git-send-email-Karthik.188@gmail.com>
On Sun, Jan 31, 2016 at 12:42 PM, Karthik Nayak <karthik.188@gmail.com> wrote:
Show 14 quoted lines
> Parsing atoms is done in populate_value(), this is repetitive and
> hence expensive. Introduce a parsing function which would let us parse
> atoms beforehand and store the required details into the 'used_atom'
> structure for further usage.
>
> Helped-by: Eric Sunshine <sunshine@sunshineco.com>
> Signed-off-by: Karthik Nayak <Karthik.188@gmail.com>
> ---
> diff --git a/ref-filter.c b/ref-filter.c
> @@ -36,6 +36,7 @@ static int need_color_reset_at_eol;
>  static struct {
>         const char *name;
>         cmp_type cmp_type;
> +       void (*parser)(struct used_atom *atom, const char *arg);

It's a little bit weird to pass in 'arg' as an additional argument considering that the parser already has access to the same information via the atom's 'name' field. I guess you're doing it as a convenience so that parsers don't have to do the strchr(':') or memchr(':') themselves (and because parse_ref_filter_atom() already has the information at hand), right? A typical parser interested in a (possibly optional) argument currently looks like this:

    void parse_foo(struct used_atom *a, const char *arg) {
        if (!arg)
            /* default behavior: arg absent */
        else
            /* process arg */
    }
That doesn't change much if you drop the 'arg' argument:
    void parse_foo(struct used_atom *a) {
        const char *arg = strchr(a->name, ':')
        if (!arg)
            /* default behavior: arg absent */
        else
            /* process arg */
    }

It does mean a very minimal amount of duplicated code (the single strchr() line per parser), but it also would remove a bit of the complexity which this patch adds to parse_ref_filter_atom(). So, I dunno...

Show 12 quoted lines
>  } valid_atom[] = {
>         { "refname" },
>         { "objecttype" },
> @@ -138,10 +140,9 @@ int parse_ref_filter_atom(const char *atom, const char *ep)
>                  * shouldn't be used for checking against the valid_atom
>                  * table.
>                  */
> -               const char *formatp = strchr(sp, ':');
> -               if (!formatp || ep < formatp)
> -                       formatp = ep;
> -               if (len == formatp - sp && !memcmp(valid_atom[i].name, sp, len))
> +               arg = memchr(sp, ':', ep - sp);

Why this change from strchr() to memchr()? I understand that you're taking advantage of the fact that you know the extent of the string via 'sp' and 'ep', however, was the original strchr() doing extra work? Even if this change is desirable, it seems somewhat unrelated to the overall purpose of this patch, thus might deserves its own.

Aside from that, although the "expensive" strchr() / memchr() resides within the loop, it will always return the same value since it doesn't depend upon any condition local to the loop. This implies that it ought to be hoisted out of the loop. (This problem is not new to this patch; it's already present in the existing code.)

Show 11 quoted lines
> +               if ((!arg || len == arg - sp) &&
> +                   !memcmp(valid_atom[i].name, sp, len))
>                         break;
>         }
>
> @@ -154,6 +155,10 @@ int parse_ref_filter_atom(const char *atom, const char *ep)
>         REALLOC_ARRAY(used_atom, used_atom_cnt);
>         used_atom[at].name = xmemdupz(atom, ep - atom);
>         used_atom[at].type = valid_atom[i].cmp_type;
> +       if (arg)
> +               arg = used_atom[at].name + (arg - atom) + 1;

This is a harder to understand than it ought to be because it's difficult to tell at first glance that you don't actually care about 'arg' in relation to the original incoming string, but instead use it only to compute an offset into the string which is ultimately stored in the newly allocated used_atom[]. Re-using 'arg' for a different purpose (in a manner of speaking) confuses the issue further.

The intention might be easier to follow if you made it clear that you were interested in the *offset* of the argument in the string, rather than a pointer into the incoming string which you ultimately don't use. A variable named 'arg_offset' might go a long way toward clarifying this intention.

Show 7 quoted lines
> +       if (valid_atom[i].parser)
> +               valid_atom[i].parser(&used_atom[at], arg);
>         if (*atom == '*')
>                 need_tagged = 1;
>         if (!strcmp(used_atom[at].name, "symref"))
> --
> 2.7.0
Previous: Karthik NayakNext: Junio C Hamano
Message 10 of 46 in “ref-filter: use parsing functions”
  1. 00/12 ref-filter: use parsing functionsKarthik Nayak, Jan 31, 2016
  2. 01/12 strbuf: introduce strbuf_split_str_omit_term()Karthik Nayak, Jan 31, 2016
  3. 02/12 ref-filter: use strbuf_split_str_omit_term()Karthik Nayak, Jan 31, 2016
  4. 03/12 ref-filter: bump 'used_atom' and related code to the topKarthik Nayak, Jan 31, 2016
  5. Junio C HamanoFeb 1, 2016
  6. Karthik NayakFeb 2, 2016
  7. 03/12 ref-filter: bump 'used_atom' and related code to the topKarthik Nayak, Feb 2, 2016
  8. 04/12 ref-filter: introduce struct used_atomKarthik Nayak, Jan 31, 2016
  9. 05/12 ref-filter: introduce parsing functions for each valid atomKarthik Nayak, Jan 31, 2016
  10. Eric SunshineFeb 3, 2016
  11. Junio C HamanoFeb 4, 2016
  12. Karthik NayakFeb 6, 2016
  13. Eric SunshineFeb 7, 2016
  14. Karthik NayakFeb 7, 2016
  15. Karthik NayakFeb 6, 2016
  16. Eric SunshineFeb 7, 2016
  17. Karthik NayakFeb 7, 2016
  18. Eric SunshineFeb 7, 2016
  19. Andreas SchwabFeb 7, 2016
  20. Karthik NayakFeb 9, 2016
  21. 06/12 ref-filter: introduce color_atom_parser()Karthik Nayak, Jan 31, 2016
  22. Eric SunshineFeb 4, 2016
  23. Karthik NayakFeb 6, 2016
  24. Christian CouderFeb 6, 2016
  25. Eric SunshineFeb 7, 2016
  26. Eric SunshineFeb 7, 2016
  27. Karthik NayakFeb 7, 2016
  28. 07/12 ref-filter: introduce parse_align_position()Karthik Nayak, Jan 31, 2016
  29. 08/12 ref-filter: introduce align_atom_parser()Karthik Nayak, Jan 31, 2016
  30. Eric SunshineFeb 4, 2016
  31. Karthik NayakFeb 6, 2016
  32. 09/12 ref-filter: align: introduce long-form syntaxKarthik Nayak, Jan 31, 2016
  33. Eric SunshineFeb 5, 2016
  34. Karthik NayakFeb 6, 2016
  35. 11/12 ref-filter: introduce contents_atom_parser()Karthik Nayak, Jan 31, 2016
  36. Eric SunshineFeb 5, 2016
  37. Karthik NayakFeb 7, 2016
  38. 12/12 ref-filter: introduce objectname_atom_parser()Karthik Nayak, Jan 31, 2016
  39. Junio C HamanoFeb 1, 2016
  40. Eric SunshineFeb 2, 2016
  41. Karthik NayakFeb 2, 2016
  42. Eric SunshineFeb 5, 2016
  43. Eric SunshineFeb 2, 2016
  44. Karthik NayakFeb 2, 2016
  45. Eric SunshineFeb 5, 2016
  46. Karthik NayakFeb 6, 2016

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.