git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH v4 05/12] ref-filter: introduce parsing functions for each valid atom

From
Eric Sunshine <sunshine@sunshineco.com>
Date
Feb 7, 2016, 07:03 UTC
Message-ID
<CAPig+cQo---uvFJeiR1FRO3hmyHFV+on6ajwcmrAeYU4uScu5Q@mail.gmail.com>
In-Reply-To
<CAOLa=ZT6aHxT6C5jc9x=YT+AaeTq7=WCcsWHjAYeg3pWF9sVVA@mail.gmail.com>
On Sat, Feb 6, 2016 at 9:36 AM, Karthik Nayak <karthik.188@gmail.com> wrote:
Show 22 quoted lines
> On Thu, Feb 4, 2016 at 3:49 AM, Eric Sunshine <sunshine@sunshineco.com> wrote:
>> On Sun, Jan 31, 2016 at 12:42 PM, Karthik Nayak <karthik.188@gmail.com> wrote:
>>> -               const char *formatp = strchr(sp, ':');
>>> -               if (!formatp || ep < formatp)
>>> -                       formatp = ep;
>>> -               if (len == formatp - sp && !memcmp(valid_atom[i].name, sp, len))
>>> +               arg = memchr(sp, ':', ep - sp);
>>
>> Why this change from strchr() to memchr()? I understand that you're
>> taking advantage of the fact that you know the extent of the string
>> via 'sp' and 'ep', however, was the original strchr() doing extra
>> work? Even if this change is desirable, it seems somewhat unrelated to
>> the overall purpose of this patch, thus might deserves its own.
>>
>> Aside from that, although the "expensive" strchr() / memchr() resides
>> within the loop, it will always return the same value since it doesn't
>> depend upon any condition local to the loop. This implies that it
>> ought to be hoisted out of the loop. (This problem is not new to this
>> patch; it's already present in the existing code.)
>
> I'm thinking I'll make a patch for that separately. i.e remove strchr()
> and introduce memchr() outside the loop.

I'd almost suggest making it two patches: (1) change strchr() to memchr(), and (2) hoist it outside the loop. However, it would be nice to see this series land with v5, and adding more refactoring patches could delay its landing if problems are found with those new patches. Consequently, it might make sense to forego any additional refactoring for now and just keep the patch as is, except for fixing the relatively minor issues (and bug or two) raised in the v4 review. If you take that approach, then hoisting memchr() out of the loop can be done as a follow-up patch after this series lands.

Show 33 quoted lines
>>> +               if ((!arg || len == arg - sp) &&
>>> +                   !memcmp(valid_atom[i].name, sp, len))
>>>                         break;
>>>         }
>>>
>>> @@ -154,6 +155,10 @@ int parse_ref_filter_atom(const char *atom, const char *ep)
>>>         REALLOC_ARRAY(used_atom, used_atom_cnt);
>>>         used_atom[at].name = xmemdupz(atom, ep - atom);
>>>         used_atom[at].type = valid_atom[i].cmp_type;
>>> +       if (arg)
>>> +               arg = used_atom[at].name + (arg - atom) + 1;
>>
>> This is a harder to understand than it ought to be because it's
>> difficult to tell at first glance that you don't actually care about
>> 'arg' in relation to the original incoming string, but instead use it
>> only to compute an offset into the string which is ultimately stored
>> in the newly allocated used_atom[]. Re-using 'arg' for a different
>> purpose (in a manner of speaking) confuses the issue further.
>>
>> The intention might be easier to follow if you made it clear that you
>> were interested in the *offset* of the argument in the string, rather
>> than a pointer into the incoming string which you ultimately don't
>> use. A variable named 'arg_offset' might go a long way toward
>> clarifying this intention.
>
> I hope you mean something like this.
>
> if (arg) {
>     int arg_offset;
>
>     arg_offset = (arg - atom) + 1;
>     arg = used_atom[at].name + arg_offset;
> }

That's one way, but I was actually thinking about computing arg_offset earlier in the "is it a valid atom?" loop, which would make it clear that you care only about the offset at that point, rather than the pointer to the ':' in the original string (since that pointer is never itself used other than to compute the offset). However, having tried it myself, the code ends up being nosier, thus not necessarily a win, so maybe just leave this as is for now.

Previous: Karthik NayakNext: Karthik Nayak
Message 13 of 46 in “ref-filter: use parsing functions”
  1. 00/12 ref-filter: use parsing functionsKarthik Nayak, Jan 31, 2016
  2. 01/12 strbuf: introduce strbuf_split_str_omit_term()Karthik Nayak, Jan 31, 2016
  3. 02/12 ref-filter: use strbuf_split_str_omit_term()Karthik Nayak, Jan 31, 2016
  4. 03/12 ref-filter: bump 'used_atom' and related code to the topKarthik Nayak, Jan 31, 2016
  5. Junio C HamanoFeb 1, 2016
  6. Karthik NayakFeb 2, 2016
  7. 03/12 ref-filter: bump 'used_atom' and related code to the topKarthik Nayak, Feb 2, 2016
  8. 04/12 ref-filter: introduce struct used_atomKarthik Nayak, Jan 31, 2016
  9. 05/12 ref-filter: introduce parsing functions for each valid atomKarthik Nayak, Jan 31, 2016
  10. Eric SunshineFeb 3, 2016
  11. Junio C HamanoFeb 4, 2016
  12. Karthik NayakFeb 6, 2016
  13. Eric SunshineFeb 7, 2016
  14. Karthik NayakFeb 7, 2016
  15. Karthik NayakFeb 6, 2016
  16. Eric SunshineFeb 7, 2016
  17. Karthik NayakFeb 7, 2016
  18. Eric SunshineFeb 7, 2016
  19. Andreas SchwabFeb 7, 2016
  20. Karthik NayakFeb 9, 2016
  21. 06/12 ref-filter: introduce color_atom_parser()Karthik Nayak, Jan 31, 2016
  22. Eric SunshineFeb 4, 2016
  23. Karthik NayakFeb 6, 2016
  24. Christian CouderFeb 6, 2016
  25. Eric SunshineFeb 7, 2016
  26. Eric SunshineFeb 7, 2016
  27. Karthik NayakFeb 7, 2016
  28. 07/12 ref-filter: introduce parse_align_position()Karthik Nayak, Jan 31, 2016
  29. 08/12 ref-filter: introduce align_atom_parser()Karthik Nayak, Jan 31, 2016
  30. Eric SunshineFeb 4, 2016
  31. Karthik NayakFeb 6, 2016
  32. 09/12 ref-filter: align: introduce long-form syntaxKarthik Nayak, Jan 31, 2016
  33. Eric SunshineFeb 5, 2016
  34. Karthik NayakFeb 6, 2016
  35. 11/12 ref-filter: introduce contents_atom_parser()Karthik Nayak, Jan 31, 2016
  36. Eric SunshineFeb 5, 2016
  37. Karthik NayakFeb 7, 2016
  38. 12/12 ref-filter: introduce objectname_atom_parser()Karthik Nayak, Jan 31, 2016
  39. Junio C HamanoFeb 1, 2016
  40. Eric SunshineFeb 2, 2016
  41. Karthik NayakFeb 2, 2016
  42. Eric SunshineFeb 5, 2016
  43. Eric SunshineFeb 2, 2016
  44. Karthik NayakFeb 2, 2016
  45. Eric SunshineFeb 5, 2016
  46. Karthik NayakFeb 6, 2016

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.