Re: [PATCH 1/2] test-lib: tests skipped by GIT_SKIP_TESTS say so
On Mon, Mar 3, 2014 at 5:24 AM, Ilya Bobyr <ilya.bobyr@gmail.com> wrote:
> We used to show "(missing )" next to tests skipped because they are
> specified in GIT_SKIP_TESTS. Use "(matched by GIT_SKIP_TESTS)" instead.
Bikeshedding: That's pretty verbose. Perhaps just say "(excluded)"?
Show 49 quoted lines
> ---
> t/test-lib.sh | 13 ++++++++-----
> 1 files changed, 8 insertions(+), 5 deletions(-)
>
> diff --git a/t/test-lib.sh b/t/test-lib.sh
> index 1531c24..89a405b 100644
> --- a/t/test-lib.sh
> +++ b/t/test-lib.sh
> @@ -446,25 +446,28 @@ test_finish_ () {
>
> test_skip () {
> to_skip=
> + skipped_reason=
> if match_pattern_list $this_test.$test_count $GIT_SKIP_TESTS
> then
> to_skip=t
> + skipped_reason="matched GIT_SKIP_TESTS"
> fi
> if test -z "$to_skip" && test -n "$test_prereq" &&
> ! test_have_prereq "$test_prereq"
> then
> to_skip=t
> - fi
> - case "$to_skip" in
> - t)
> +
> of_prereq=
> if test "$missing_prereq" != "$test_prereq"
> then
> of_prereq=" of $test_prereq"
> fi
> -
> + skipped_reason="missing $missing_prereq${of_prereq}"
> + fi
> + case "$to_skip" in
> + t)
> say_color skip >&3 "skipping test: $@"
> - say_color skip "ok $test_count # skip $1 (missing $missing_prereq${of_prereq})"
> + say_color skip "ok $test_count # skip $1 ($skipped_reason)"
> : true
> ;;
> *)
> --
> 1.7.9
>
> --
> To unsubscribe from this list: send the line "unsubscribe git" in
> the body of a message to majordomo@vger.kernel.org
> More majordomo info at http://vger.kernel.org/majordomo-info.html