Re: [GSoC][PATCH v3] test: avoid pipes in git related commands for test
- From
Eric Sunshine <sunshine@sunshineco.com>
- Date
- Mar 21, 2018, 18:45 UTC
- Message-ID
- <CAPig+cQ1KSL8LreoE7waBzqz2V1N0rwLujDCM82nqTdgF=MC3g@mail.gmail.com>
- In-Reply-To
- <xmqqo9jhpadh.fsf@gitster-ct.c.googlers.com>
On Wed, Mar 21, 2018 at 2:11 PM, Junio C Hamano <gitster@pobox.com> wrote:
Show 10 quoted lines
> Pratik Karki <predatoramigo@gmail.com> writes: >> The changes in patch increased from v1 to v2 because I >> got excited to work in Git codebase and I tried to >> fix the exisiting problems as much as possible. >> Hence, the large number of changes. > > Eric understands why the scope was increased between the two; he > explained why it is not a good idea to increase the scope in the > middle, and I tend to agree with his reasoning. The reason why the > scope was increased does not matter.
Thanks, Junio. I had just started writing a review of v3 when your review arrived, and you covered every point I was going to make, thus saved me the effort. I agree with everything in your review.
One additional comment, Pratik, is that this patch seems to be based upon a slightly old version of the Git source code, thus does not apply cleanly to present-day 'master'. Before re-rolling, update to the latest Git and rebase your patch atop it.
Show 9 quoted lines
>> - PACK5=$( git rev-list --objects "$LIST" "$LI" "$ST" | \ >> - git pack-objects test-5 ) && >> - PACK6=$( ( >> + git rev-list --objects "$LIST" "$LI" "$ST" >actual && >> + PACK5=$( git pack-objects test-5 <actual ) && >> + PACK6=$(( > > I thought that Eric already pointed out and explained why this > change to PACK6 is wrong in the previous round?
I probably should have been more explicit by naming PACK6 directly. Comparing v3 against v2, I see that Pratik probably misunderstood my comment, thinking that I was talking about losing the whitespace inside PACK5=$(...); v2 dropped that whitespace and v3 restored it.
Pratik, dropping the unnecessary whitespace inside PACK5=$(...) is fine (no complaint about that), but changing PACK6=$( (...) ) to PACK6=$((...)) is outright incorrect as explained in [1].
[1]: https://public-inbox.org/git/CAPig+cTKkp6kpFcJfVV8W1ejCrCWQH33mHtgFUn+MpMgw5i1pA@mail.gmail.com/