git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH v3 4/4] ref-filter: add support for %(contents:size)

From
Christian Couder <christian.couder@gmail.com>
Date
Jul 9, 2020, 08:10 UTC
Message-ID
<CAP8UFD2tUUgwjhkizihhqHc0LUYN_gS=wZCtXroLVtT3kMyqLw@mail.gmail.com>
In-Reply-To
<xmqqtuyhzgro.fsf@gitster.c.googlers.com>
On Thu, Jul 9, 2020 at 2:14 AM Junio C Hamano <gitster@pobox.com> wrote:
Show 19 quoted lines
>
> Junio C Hamano <gitster@pobox.com> writes:
>
> > Of course, we _could_ update the test_atom to do something magic
> > only when the 'contents' atom is being asked.  We notice that $2 is
> > 'contents', do the usual test_expect_success for 'contents', and
> > then measure the byte length of $3 ourselves and test
> > 'contents:size'.  That way, all the above test updates would become
> > unnecessary (and the last two hunks of this patch can also go).
> >
> > That approach may even allow you to hide the details of sanitize-pgp
> > in the updated test_atom so that the actual tests may not have to get
> > updated even for signed tags.
>
> After seeing the "wc -c" portability issues, I am now even more
> inclined to say that the above is the right direction.  The
> portability worries can and should be encapsulated in a single
> test_atom helper function, just as it can be used to hide the
> differences between signed tags, annotated tags and commits.

Yeah, I have been working on that and will send a new patch series soon. The current test_atom() change looks like this:

diff --git a/t/t6300-for-each-ref.sh b/t/t6300-for-each-ref.sh
index 371e45e5ad..e514d98574 100755
--- a/t/t6300-for-each-ref.sh
+++ b/t/t6300-for-each-ref.sh
@@ -52,6 +52,26 @@ test_atom() {
                sanitize_pgp <actual >actual.clean &&
                test_cmp expected actual.clean
        "
+       # Automatically test "contents:size" atom after testing "contents"
+       if test "$2" = "contents"
+       then
+               case "$1" in
+               refs/tags/signed-*)
+                       # We cannot use $3 as it expects sanitize_pgp to run
+                       git cat-file tag $ref | tail -n +6 | \
+                               wc -c | sed -e 's/^ *//' >expected ;;
+               refs/mytrees/*)
+                       echo >expected ;;
+               refs/myblobs/*)
+                       echo >expected ;;
+               *)
+                       printf '%s' "$3" | wc -c | sed -e 's/^ *//' >expected ;;
+               esac
+               test_expect_${4:-success} $PREREQ "basic atom: $1 $2:size" "
+                       git for-each-ref --format='%($2:size)' $ref >actual &&
+                       test_cmp expected actual
+               "
+       fi
 }

I am wondering if it's worth adding a preparatory patch to introduce
an helper function like the following in test-lib-functions.sh:

+# test_byte_count outputs the number of bytes in files or stdin
+#
+# It is like wc -c but without portability issues, as on macOS and
+# possibly other platforms leading whitespaces are emitted before the
+# number.
+
+test_byte_count () {
+       wc -c "$@" | sed -e 's/^ *//'
+}

Not sure about the name of this helper function as it works
differently than test_line_count().
Previous: Junio C HamanoNext: Junio C Hamano
Message 12 of 39 in “Add support for %(contents:size) in ref-filter”
  1. 0/4 Add support for %(contents:size) in ref-filterChristian Couder, Jul 7, 2020
  2. 1/4 Documentation: clarify %(contents:XXXX) docChristian Couder, Jul 7, 2020
  3. Junio C HamanoJul 7, 2020
  4. Christian CouderJul 10, 2020
  5. 2/4 Documentation: clarify 'complete message'Christian Couder, Jul 7, 2020
  6. Junio C HamanoJul 7, 2020
  7. 3/4 t6300: test refs pointing to tree and blobChristian Couder, Jul 7, 2020
  8. Junio C HamanoJul 7, 2020
  9. 4/4 ref-filter: add support for %(contents:size)Christian Couder, Jul 7, 2020
  10. Junio C HamanoJul 7, 2020
  11. Junio C HamanoJul 9, 2020
  12. Christian CouderJul 9, 2020
  13. Junio C HamanoJul 9, 2020
  14. Junio C HamanoJul 7, 2020
  15. Junio C HamanoJul 8, 2020
  16. 0/3 Add support for %(contents:size) in ref-filterChristian Couder, Jul 10, 2020
  17. 1/3 Documentation: clarify %(contents:XXXX) docChristian Couder, Jul 10, 2020
  18. Junio C HamanoJul 10, 2020
  19. 3/3 ref-filter: add support for %(contents:size)Christian Couder, Jul 10, 2020
  20. Junio C HamanoJul 10, 2020
  21. 2/3 t6300: test refs pointing to tree and blobChristian Couder, Jul 10, 2020
  22. Junio C HamanoJul 10, 2020
  23. 0/3 Add support for %(contents:size) in ref-filterChristian Couder, Jul 16, 2020
  24. 1/3 Documentation: clarify %(contents:XXXX) docChristian Couder, Jul 16, 2020
  25. 2/3 t6300: test refs pointing to tree and blobChristian Couder, Jul 16, 2020
  26. 3/3 ref-filter: add support for %(contents:size)Christian Couder, Jul 16, 2020
  27. Alban GruinJul 31, 2020
  28. t6300: fix issues related to %(contents:size)Alban Gruin, Jul 31, 2020
  29. Jeff KingJul 31, 2020
  30. Alban GruinJul 31, 2020
  31. Junio C HamanoJul 31, 2020
  32. Jeff KingJul 31, 2020
  33. t6300: fix issues related to %(contents:size)Alban Gruin, Jul 31, 2020
  34. Jeff KingJul 31, 2020
  35. Jeff KingJul 31, 2020
  36. Christian CouderJul 31, 2020
  37. Junio C HamanoJul 31, 2020
  38. Jeff KingJul 31, 2020
  39. Junio C HamanoJul 16, 2020

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.