Re: [PATCH v2] rebase -i: add config to abbreviate command-names
- From
Mike Rappazzo <rappazzo@gmail.com>
- Date
- Apr 25, 2017, 13:59 UTC
- Message-ID
- <CANoM8SUoMVL4TRGSPYRXOuj0-=QUOJPWss8Uy-pq5VYYEbjAzQ@mail.gmail.com>
- In-Reply-To
- <87vapsq073.fsf@linux-m68k.org>
On Tue, Apr 25, 2017 at 5:57 AM, Andreas Schwab <schwab@linux-m68k.org> wrote:
Show 19 quoted lines
> On Apr 25 2017, Liam Beguin <liambeguin@gmail.com> wrote: > >> Add the 'rebase.abbrevCmd' boolean config option to allow `git rebase -i` >> to abbreviate the command-names in the instruction list. >> >> This means that `git rebase -i` would print: >> p deadbee The oneline of this commit >> ... >> >> instead of: >> pick deadbee The oneline of this commit >> ... >> >> Using a single character command-name allows the lines to remain >> aligned, making the whole set more readable. > > Perhaps there should rather be an option to tell rebase to align the > columns? >
You _can_ set a custom instruction format using the config variable: `rebase.instructionFormat`. With this, you can align columns using the normal git log format.
For example, I personally use this as my instruction format:
[%an%<|(64)%x5d %s
While, this won't always align perfectly, it may help scratch your itch.