From: Mike Rappazzo Date: Tue, 25 Apr 2017 13:59:56 GMT Subject: Re: [PATCH v2] rebase -i: add config to abbreviate command-names Message-ID: In-Reply-To: <87vapsq073.fsf@linux-m68k.org> On Tue, Apr 25, 2017 at 5:57 AM, Andreas Schwab wrote: > On Apr 25 2017, Liam Beguin wrote: > >> Add the 'rebase.abbrevCmd' boolean config option to allow `git rebase -i` >> to abbreviate the command-names in the instruction list. >> >> This means that `git rebase -i` would print: >> p deadbee The oneline of this commit >> ... >> >> instead of: >> pick deadbee The oneline of this commit >> ... >> >> Using a single character command-name allows the lines to remain >> aligned, making the whole set more readable. > > Perhaps there should rather be an option to tell rebase to align the > columns? > You _can_ set a custom instruction format using the config variable: `rebase.instructionFormat`. With this, you can align columns using the normal git log format. For example, I personally use this as my instruction format: [%an%<|(64)%x5d %s While, this won't always align perfectly, it may help scratch your itch.