Re: [PATCH v3 1/3] test-lib-functions: handle --add in test_config
- From
Nipunn Koorapati <nipunn1313@gmail.com>
- Date
- Dec 22, 2020, 00:00 UTC
- Message-ID
- <CAN8Z4-UG-watOnJMYUe3KU4JHnmJTxvwKSZ3s2DtBg104PACaA@mail.gmail.com>
- In-Reply-To
- <CAPig+cRqa9Y4mEdktdP3d2+PHWanKZ6q6tXfJXEAW9sqcVwHOw@mail.gmail.com>
Show 8 quoted lines
> I forgot to mention that it likely would be a good idea to at least > mention in the commit message why test_config() is not being used for > that particular case. Perhaps saying something along the lines of "one > test handles config cleanup manually since test_config() is not > prepared to take arbitrary options such as --add" -- or something > along those lines -- would be sufficient. Alternatively, an in-code > comment within the test explaining the open-coding might be more > helpful to people reading the code in the future.
I found that since test_unconfig uses --unset-all, I can write a test as such
test_config -C two remote.one.push +: &&
test_must_fail git -C two push one &&
git -C two config --add remote.one.push ^refs/heads/master &&
git -C two push oneThe unconfig of the test_config will --unset-all remote.one.push. I can use this technique and add a comment to that extent.
--Nipunn