From: Nipunn Koorapati Date: Tue, 22 Dec 2020 00:00:29 GMT Subject: Re: [PATCH v3 1/3] test-lib-functions: handle --add in test_config Message-ID: In-Reply-To: > I forgot to mention that it likely would be a good idea to at least > mention in the commit message why test_config() is not being used for > that particular case. Perhaps saying something along the lines of "one > test handles config cleanup manually since test_config() is not > prepared to take arbitrary options such as --add" -- or something > along those lines -- would be sufficient. Alternatively, an in-code > comment within the test explaining the open-coding might be more > helpful to people reading the code in the future. I found that since test_unconfig uses --unset-all, I can write a test as such test_config -C two remote.one.push +: && test_must_fail git -C two push one && git -C two config --add remote.one.push ^refs/heads/master && git -C two push one The unconfig of the test_config will --unset-all remote.one.push. I can use this technique and add a comment to that extent. --Nipunn