Re: [PATCH v3 1/2] git-merge-file doc: drop "-file" from argument placeholders
- From
- Martin Ågren <martin.agren@gmail.com>
- Date
- Nov 2, 2023, 08:53 UTC
- Message-ID
- <CAN0heSrv7MPcEwkq4uEtv9uBbqm4FLKQLE3gdsEbqKkxPXOj5A@mail.gmail.com>
- In-Reply-To
- <xmqq8r7howsq.fsf@gitster.g>
On Thu, 2 Nov 2023 at 00:53, Junio C Hamano <gitster@pobox.com> wrote:
Show 12 quoted lines
> > "brian m. carlson" <sandals@crustytoothpaste.net> writes: > > > From: Martin Ågren <martin.agren@gmail.com> > > > > `git merge-file` takes three positional arguments. Each of them is > > documented as `<foo-file>`. In preparation for teaching this command to > > alternatively take three object IDs, make these placeholders a bit more > > Minor nit. Don't we want to say "three blob object names"? Unless > we plan to grow this feature into accepting three tree object names, > that is.
Hmm, yeah. Or just "three non-filename arguments". I do wonder: doesn't this mean that the second patch could/should possibly move away from the notion of "object ID"/`--object-id`? (That's not trying to shift any blame from one patch to the other, that's my honest reaction.)
Ah, yes, I thought I recognized this. Quoting your response [1] to v2:
Show 5 quoted lines
> I briefly thought about suggesting --blob-id instead of --object-id > simply because you'd never want to feed it trees and commits, but > the error message from read_mmblob() the users would get mentions > 'blob' to signal that non-blob objects are unwelcome, so the name of > the optionwould be OK as-is.
Maybe you having a similar reaction a second time makes this smell a bit more?
[1] https://lore.kernel.org/git/xmqqo7ge2xzl.fsf@gitster.g/
Martin