Re: [PATCH 1/2] diff: Fix modified lines stats with --stat and --numstat
- From
Thomas Guyot-Sionnest <tguyot@gmail.com>
- Date
- Sep 18, 2020, 17:52 UTC
- Message-ID
- <CALqVohcZrBcjmonw-peVxUNM1kgEheCr3nAk9ZvajGpbpXsNaQ@mail.gmail.com>
- In-Reply-To
- <20200918172747.GD183026@coredump.intra.peff.net>
On Fri, 18 Sep 2020 at 13:27, Jeff King <peff@peff.net> wrote:
Show 7 quoted lines
> On Fri, Sep 18, 2020 at 07:32:55AM -0400, Thomas Guyot-Sionnest wrote: > > This patch checks if is_stdin flag is set on both sides and compare > > contents directly. > > I'm somewhat puzzled how we could have two filespecs that came from > stdin, since we'd generally read to EOF. But looking at the test, it > seems this is a weird range-diff hack to set is_stdin.
"is_stdin" is actually set manually by a function that copies stdin to diff_filespec->data. We can get an arbitrary number of pipes from command line arguments - only difference with stdin is that we have to open them before read.
The flag seems to have been leveraged by diff-range - the first patch fixes that tool alone, and 2nd adds support for multiple pipes in --no-index. Both are independent but you would not be able to --stat two pipes without the first patch.
Show 17 quoted lines
> > diff --git a/diff.c b/diff.c > > index a5114fa864..2995527896 100644 > > --- a/diff.c > > +++ b/diff.c > > @@ -3681,7 +3681,10 @@ static void builtin_diffstat(const char *name_a, const char *name_b, > > return; > > } > > > > - same_contents = oideq(&one->oid, &two->oid); > > + if (one->is_stdin && two->is_stdin) > > + same_contents = !strcmp(one->data, two->data); > > + else > > + same_contents = oideq(&one->oid, &two->oid); > > ...should this actually be checking the oid_valid flag in each filespec? > That would presumably cover the is_stdin case, too. I also wonder > whether range-diff ought to be using that flag instead of is_stdin.
I considered that, but IIRC when run under a debugger oid_valid was set to 0 - it seemed to be used for something different that i'm not familiar with, maybe it's an indication the object is in git datastore (whereas with --no-index outside files will only be hashed for comparison).
I think is_stdin is a misnomer, but if we want to refactor that i'd rather do it after.
Regards,
Thomas