Re: [RFC PATCH 05/13] upload-pack: refactor ok_to_give_up()
- From
Stefan Beller <sbeller@google.com>
- Date
- Jun 29, 2018, 21:44 UTC
- Message-ID
- <CAGZ79kbMSnTqyJY8Ds6gsyy9saCmWW3jdELsS9RkO2a3isP5zA@mail.gmail.com>
- In-Reply-To
- <20180629161223.229661-6-dstolee@microsoft.com>
Hi Derrick,
> -static int ok_to_give_up(void) > +static int can_all_from_reach_with_flag(struct object_array from,
This method is hard to read; at first I thought you missed a word, but then I realized that it asks "can all 'from' members reach ['something'] and we pass in the 'flag', so maybe
all_reachable_flags
or something?
> /* no way to tell if this is reachable by
While at it, you may want to fix the comment here.