Re: [GSOC PATCH 2/2] builtin/prune: stop depending on 'the_repository'
On Sat, Jun 28, 2025 at 1:02 PM shejialuo <shejialuo@gmail.com> wrote:
Show 16 quoted lines
>
> On Sun, Jun 08, 2025 at 06:36:35AM +0530, Ayush Chandekar wrote:
>
> [snip]
>
> > @@ -99,7 +98,7 @@ static int prune_object(const struct object_id *oid, const char *fullpath,
> > if (st.st_mtime > expire)
> > return 0;
> > if (show_only || verbose) {
> > - enum object_type type = oid_object_info(the_repository, oid,
> > + enum object_type type = oid_object_info(revs->repo, oid,
> > NULL);
>
> Could we simply make `NULL` in the same line by the way? The readability
> would be better.
>Yeah, I agree, will do that.
Show 38 quoted lines
> > printf("%s %s\n", oid_to_hex(oid),
> > (type > 0) ? type_name(type) : "unknown");
> > @@ -154,7 +153,7 @@ static void remove_temporary_files(const char *path)
> > int cmd_prune(int argc,
> > const char **argv,
> > const char *prefix,
> > - struct repository *repo UNUSED)
> > + struct repository *repo)
> > {
> > struct rev_info revs;
> > int exclude_promisor_objects = 0;
> > @@ -173,19 +172,19 @@ int cmd_prune(int argc,
> > expire = TIME_MAX;
> > save_commit_buffer = 0;
> > disable_replace_refs();
> > - repo_init_revisions(the_repository, &revs, prefix);
> > + repo_init_revisions(repo, &revs, prefix);
> >
> > argc = parse_options(argc, argv, prefix, options, prune_usage, 0);
> >
> > - if (the_repository->repository_format_precious_objects)
> > + if (repo->repository_format_precious_objects)
> > die(_("cannot prune in a precious-objects repo"));
> >
> > while (argc--) {
> > struct object_id oid;
> > const char *name = *argv++;
> >
> > - if (!repo_get_oid(the_repository, name, &oid)) {
> > - struct object *object = parse_object_or_die(the_repository, &oid,
> > + if (!repo_get_oid(repo, name, &oid)) {
> > + struct object *object = parse_object_or_die(repo, &oid,
> > name);
>
> Same, could we just make `name` in the same line. There is no need for
> the newline right now as we change "the_repository" to "repo" which
> would reduce some columns.
>> Thanks,
> Jialuo