Re: [PATCH] Revert "gitweb: Time::HiRes is in core for Perl 5.8"
- From
Ævar Arnfjörð Bjarmason <avarab@gmail.com>
- Date
- Jan 29, 2012, 02:29 UTC
- Message-ID
- <CACBZZX4KOc6Roz7U5rLrNnzJ_JY9WsSyV6zU_KOsHC+A8y7w4w@mail.gmail.com>
- In-Reply-To
- <7vty3gzxhs.fsf@alter.siamese.dyndns.org>
On Fri, Jan 27, 2012 at 21:44, Junio C Hamano <gitster@pobox.com> wrote:
Show 7 quoted lines
> > if (defined $t0) > > If you go this route, even though tee-zero, the beginning of the > time, is a good name for the variable, you may want to rename it to > avoid confusing readers who might take it as a temporary variable > #0.
<trivia>
Personally I'd have written it as $START_TIME, but as a bit of Perl trivia you might not realize $t0 is a commonly used and undestood variable for dealing with a start time in Perl in the same way that `i` is common for dealing with array indexes in C.
I.e. someone used to Perl will immediately think "oh that's the start time" having seen it hundreds of times before, but someone not used to Perl will go "what's this t-zero thing?".
Meanwhile some Lisp programmer is wondering what the hell "i" means in your C for-loops, iterator? :)