From: Ævar Arnfjörð Bjarmason Date: Sun, 29 Jan 2012 02:29:09 GMT Subject: Re: [PATCH] Revert "gitweb: Time::HiRes is in core for Perl 5.8" Message-ID: In-Reply-To: <7vty3gzxhs.fsf@alter.siamese.dyndns.org> On Fri, Jan 27, 2012 at 21:44, Junio C Hamano wrote: > >        if (defined $t0) > > If you go this route, even though tee-zero, the beginning of the > time, is a good name for the variable, you may want to rename it to > avoid confusing readers who might take it as a temporary variable > #0. Personally I'd have written it as $START_TIME, but as a bit of Perl trivia you might not realize $t0 is a commonly used and undestood variable for dealing with a start time in Perl in the same way that `i` is common for dealing with array indexes in C. I.e. someone used to Perl will immediately think "oh that's the start time" having seen it hundreds of times before, but someone not used to Perl will go "what's this t-zero thing?". Meanwhile some Lisp programmer is wondering what the hell "i" means in your C for-loops, iterator? :)