Re: jk/tag-contains: stalled
- From
Jay Soffian <jaysoffian@gmail.com>
- Date
- Aug 5, 2010, 19:18 UTC
- Message-ID
- <AANLkTimzn05tvwY=uG6VP6PXDHwA=wS9ECuK_9eWKtSx@mail.gmail.com>
- In-Reply-To
- <20100805190653.GA2942@sigill>
On Thu, Aug 5, 2010 at 3:06 PM, Jeff King <peff@peff.net> wrote:
> I agree it's a pretty generic name. I was trying to make this as generic > as possible, at least within the domain of commits, so it could be a > faster replacement for calls to is_descendant_of. Maybe commit_contains?
I'm going to side-track this slightly. I wonder why branch and tag have --contains, but it is not more generically available via rev-list? I needed it the other day and spent 5 minutes looking at what it would take before I ended up just calling merge-base in a loop for the commits I wanted to check.
j.