Re: [PATCHv6 07/10] gitweb: remotes view for a single remote
- From
Giuseppe Bilotta <giuseppe.bilotta@gmail.com>
- Date
- Oct 25, 2010, 18:18 UTC
- Message-ID
- <AANLkTi=LiE3=fKdxeQU8HsKLia1ur2k2CDtqDhALj234@mail.gmail.com>
- In-Reply-To
- <201010251712.30362.jnareb@gmail.com>
2010/10/25 Jakub Narebski <jnareb@gmail.com>:
Show 8 quoted lines
> On Sun, 24 Oct 2010, Giuseppe Bilotta wrote: > >> When 'remotes' view is passed the 'hash' parameter, interpret it as the >> name of a remote and limit the view the the heads of that remote. > > I don't quite like (ab)using 'hash' parameter like that, but because > it allows us to use e.g. 'project.git/remotes/origin' path_info > without writing special code for that, I am all right with this hack.
We could rename the 'hash' parameter to be more descriptive of the fact that it includes this nature, but I really think it's not worth it.
Show 11 quoted lines
>> In single-remote view we let the user switch easily to the default
>> remotes view by specifying an -action_extra for the page header and by
>> enabling the 'remotes' link in the reference navigation submenu.
>
> Nice!
>
>> + if (defined $remote) {
>> + # only display the heads in a given remote
>
> It also strips uninteresting '<remote>/' prefix, isn't it?
> It would be nice, though not necessary, to have this in comment.Good idea.
-- Giuseppe "Oblomov" Bilotta