Re: [PATCH 4/3] Makefile: untangle DEVELOPER and -Werror
- From
Ævar Arnfjörð Bjarmason <avarab@gmail.com>
- Date
- Apr 7, 2018, 12:36 UTC
- Message-ID
- <87r2nryz0j.fsf@evledraar.gmail.com>
- In-Reply-To
- <CACsJy8BOVnu+HXcVbkTKW6YZ8vQnwbAcaF4d2CzUbQLrZjuOJg@mail.gmail.com>
On Sat, Apr 07 2018, Duy Nguyen wrote:
Show 21 quoted lines
> On Fri, Apr 6, 2018 at 11:42 PM, Jeff King <peff@peff.net> wrote: >> On Tue, Apr 03, 2018 at 05:17:00PM +0200, Duy Nguyen wrote: >> >>> It's not that complex. With the EAGER_DEVELOPER patch removed, we can >>> have something like this where eager devs just need to put >>> >>> DEVOPTS = gentle no-suppression >>> >>> and you put >>> >>> DEVOPTS = gentle >>> >>> (bad naming, I didn't spend time thinking about names) >> >> It seems to me like we're losing the point of DEVELOPER here. I thought >> the idea was to have a turn-key flag you could set to get extra linting >> on your commits. But now we're tweaking all kinds of individual options. >> At some point are we better off just letting you put "-Wno-foo" in your >> CFLAGS yourself? > > It's because what AEvar wanted is no longer a dev thing :)
It's still a dev thing, but just for a slightly different use-case. I hack my patches up with DEVELOPER=1, and then eventually deploy a patched git version with those (and others) on top of the latest release tag.
At that point I want the same compiler assertions, but might be building on much older compilers, so I just want the warning output without -Werror.
Anyway, I see you've pushed a new version with DEVOPTS. I'll submit mine on top of that once your new version lands (unless you want to try to integrate it yourself).