Re: [PATCH] Allow building with xmlparse.h
- From
Junio C Hamano <gitster@pobox.com>
- Date
- Feb 11, 2013, 22:11 UTC
- Message-ID
- <7vy5eujybf.fsf@alter.siamese.dyndns.org>
- In-Reply-To
- <1360620225-19587-1-git-send-email-kraai@ftbfs.org>
Matt Kraai <kraai@ftbfs.org> writes:
Show 22 quoted lines
> From: Matt Kraai <matt.kraai@amo.abbott.com> > > expat 1.1 and 1.2 provide xmlparse.h instead of expat.h. Include the > former on systems that define the EXPAT_NEEDS_XMLPARSE_H variable and > define that variable on QNX systems, which ship with expat 1.1. > > Signed-off-by: Matt Kraai <matt.kraai@amo.abbott.com> > --- > ... > diff --git a/http-push.c b/http-push.c > index 9923441..7202e2d 100644 > --- a/http-push.c > +++ b/http-push.c > @@ -11,7 +11,11 @@ > #include "list-objects.h" > #include "sigchain.h" > > +#ifndef EXPAT_NEEDS_XMLPARSE_H > #include <expat.h> > +#else > +#include <xmlparse.h> > +#endif
Thanks for a quick re-roll.
Is it just me who finds the above hard to read and find the below much more natural?
#ifdef NEEDS_FOO_H
#include <foo.h>
#else
#include <bar.h>
#endif