Re: [PATCH] Allow building with xmlparse.h
- From
Junio C Hamano <gitster@pobox.com>
- Date
- Feb 11, 2013, 22:35 UTC
- Message-ID
- <7vtxpijx7r.fsf@alter.siamese.dyndns.org>
- In-Reply-To
- <1360621855-19863-1-git-send-email-kraai@ftbfs.org>
Matt Kraai <kraai@ftbfs.org> writes:
Show 16 quoted lines
> From: Matt Kraai <matt.kraai@amo.abbott.com> > > expat 1.1 and 1.2 provide xmlparse.h instead of expat.h. Include the > former on systems that define the EXPAT_NEEDS_XMLPARSE_H variable and > define that variable on QNX systems, which ship with expat 1.1. > > Signed-off-by: Matt Kraai <matt.kraai@amo.abbott.com> > --- > Makefile | 6 ++++++ > config.mak.uname | 1 + > http-push.c | 4 ++++ > 3 files changed, 11 insertions(+) > > I've changed #ifndef to #ifdef and changed the order of the branches > in http-push.c. If you'd also like me to rename the variable (e.g., > to NEEDS_XMLPARSE_H), please let me know.
I do not think renaming is necessary (the name you used in the original and this patch is better than NEEDS_XMLPARSE_H).
I take that you also think the updated order is easier to read; thanks for sanity-checking ;-).