git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH 1/3] vcs-svn: rename check_overflow arguments for clarity

From
Junio C Hamano <gitster@pobox.com>
Date
Feb 2, 2012, 18:56 UTC
Message-ID
<7vr4ydvzcs.fsf@alter.siamese.dyndns.org>
In-Reply-To
<20120202112732.GA15537@burratino>
Ok, I've tentatively queued this.
-- >8 --
From: Ramsay Jones <ramsay@ramsay1.demon.co.uk>

Code using the argument names a and b just doesn't look right (not sure why!). Use more explicit names "offset" and "len" to make their type and meaning clearer.

Also rename check_overflow() to check_offset_overflow() to clarify that we are making sure that "len" bytes beyond "offset" still fits the type to represent an offset.

Signed-off-by: Jonathan Nieder <jrnieder@gmail.com>
Signed-off-by: Junio C Hamano <gitster@pobox.com>
---
 vcs-svn/sliding_window.c |   14 +++++++-------
 1 files changed, 7 insertions(+), 7 deletions(-)
diff --git a/vcs-svn/sliding_window.c b/vcs-svn/sliding_window.c
index 1bac7a4..c6c2eff 100644
--- a/vcs-svn/sliding_window.c
+++ b/vcs-svn/sliding_window.c
@@ -31,15 +31,15 @@ static int read_to_fill_or_whine(struct line_buffer *file,
 	return 0;
 }
 
-static int check_overflow(off_t a, size_t b)
+static int check_offset_overflow(off_t offset, size_t len)
 {
-	if (b > maximum_signed_value_of_type(off_t))
+	if (len > maximum_signed_value_of_type(off_t))
 		return error("unrepresentable length in delta: "
-				"%"PRIuMAX" > OFF_MAX", (uintmax_t) b);
-	if (signed_add_overflows(a, (off_t) b))
+				"%"PRIuMAX" > OFF_MAX", (uintmax_t) len);
+	if (signed_add_overflows(offset, (off_t) len))
 		return error("unrepresentable offset in delta: "
 				"%"PRIuMAX" + %"PRIuMAX" > OFF_MAX",
-				(uintmax_t) a, (uintmax_t) b);
+				(uintmax_t) offset, (uintmax_t) len);
 	return 0;
 }
 
@@ -48,9 +48,9 @@ int move_window(struct sliding_view *view, off_t off, size_t width)
 	off_t file_offset;
 	assert(view);
 	assert(view->width <= view->buf.len);
-	assert(!check_overflow(view->off, view->buf.len));
+	assert(!check_offset_overflow(view->off, view->buf.len));
 
-	if (check_overflow(off, width))
+	if (check_offset_overflow(off, width))
 		return -1;
 	if (off < view->off || off + width < view->off + view->width)
 		return error("invalid delta: window slides left");
-- 
1.7.9.172.ge26ae
Previous: Jonathan NiederNext: Jonathan Nieder
Message 11 of 16 in “vcs-svn: Fix some compiler warnings”
  1. vcs-svn: Fix some compiler warningsRamsay Jones, Jan 31, 2012
  2. Jonathan NiederJan 31, 2012
  3. Junio C HamanoJan 31, 2012
  4. Junio C HamanoFeb 2, 2012
  5. 0/3 Re: [PATCH] vcs-svn: Fix some compiler warningsJonathan Nieder, Feb 2, 2012
  6. 1/3 vcs-svn: rename check_overflow arguments for clarityJonathan Nieder, Feb 2, 2012
  7. Dmitry IvankovFeb 2, 2012
  8. Jonathan NiederFeb 2, 2012
  9. David BarrFeb 2, 2012
  10. Jonathan NiederFeb 2, 2012
  11. Junio C HamanoFeb 2, 2012
  12. 2/3 vcs-svn: allow import of > 4GiB filesJonathan Nieder, Feb 2, 2012
  13. 3/3 vcs-svn: suppress a -Wtype-limits warningJonathan Nieder, Feb 2, 2012
  14. Ramsay JonesFeb 2, 2012
  15. Ramsay JonesFeb 2, 2012
  16. Jonathan NiederFeb 2, 2012

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.