[PATCH 1/3] vcs-svn: rename check_overflow arguments for clarity
- From
Jonathan Nieder <jrnieder@gmail.com>
- Date
- Feb 2, 2012, 10:59 UTC
- Message-ID
- <20120202105923.GJ3823@burratino>
- In-Reply-To
- <20120202104128.GG3823@burratino>
From: Ramsay Jones <ramsay@ramsay1.demon.co.uk>
Code using the argument names a and b just doesn't look right (not sure why!). Use more explicit names "offset" and "len" to make their type and function clearer.
Signed-off-by: Jonathan Nieder <jrnieder@gmail.com> --- Split out from Ramsay's patch.
vcs-svn/sliding_window.c | 10 +++++----- 1 files changed, 5 insertions(+), 5 deletions(-)
diff --git a/vcs-svn/sliding_window.c b/vcs-svn/sliding_window.c index 1bac7a4c..fafa4a63 100644 --- a/vcs-svn/sliding_window.c +++ b/vcs-svn/sliding_window.c @@ -31,15 +31,15 @@ static int read_to_fill_or_whine(struct line_buffer *file, return 0; } -static int check_overflow(off_t a, size_t b) +static int check_overflow(off_t offset, size_t len) { - if (b > maximum_signed_value_of_type(off_t)) + if (len > maximum_signed_value_of_type(off_t)) return error("unrepresentable length in delta: " - "%"PRIuMAX" > OFF_MAX", (uintmax_t) b); + "%"PRIuMAX" > OFF_MAX", (uintmax_t) len); - if (signed_add_overflows(a, (off_t) b)) + if (signed_add_overflows(offset, (off_t) len)) return error("unrepresentable offset in delta: " "%"PRIuMAX" + %"PRIuMAX" > OFF_MAX", - (uintmax_t) a, (uintmax_t) b); + (uintmax_t) offset, (uintmax_t) len); return 0; }
-- 1.7.9