Re: [PATCH] completion: add missing configuration variables
- From
Junio C Hamano <gitster@pobox.com>
- Date
- Dec 17, 2010, 20:44 UTC
- Message-ID
- <7vei9gi0y3.fsf@alter.siamese.dyndns.org>
- In-Reply-To
- <20101215130046.GB25647@sigill.intra.peff.net>
Jeff King <peff@peff.net> writes:
> All variables are case-insensitive. The config parser down-cases them, > so all code should treat tham as all-lowercase. However, we tend to > document them as camelCase for readability.
Careful. The second level of three-level names is supposed to be usable for user defined names (e.g. names of branches and remotes) and I think the completion code should not downcase it.