git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH] completion: add missing configuration variables

From
Jeff King <peff@peff.net>
Date
Dec 15, 2010, 13:00 UTC
Message-ID
<20101215130046.GB25647@sigill.intra.peff.net>
In-Reply-To
<1292395613-12859-1-git-send-email-martin.von.zweigbergk@gmail.com>
On Wed, Dec 15, 2010 at 07:46:53AM +0100, Martin von Zweigbergk wrote:
> The color.grep.external option has been deleted. Should it be deleted
> from here or do we want to help users run e.g.
> 'git config --unset color.grep.external'? Same goes for
> add.ignore-errors.

IMHO, they should go away. People who have them can figure out how to delete them, but it is more important not to advertise them to people who are adding variables.

As an aside, I would think "--unset" should actually choose from the set of configured variables for completion (i.e., "git config --list | cut -d= -f1"). But that would obviously be a separate patch.

> I didn't find any references to 'diff.renameLimit.' even in 98171a0
> (bash completion: Sync config variables with their man pages,
> 2008-12-15) in which it was introduced in the completions script. I
> hope it was safe to remove it.
Yeah, I don't think it has ever existed.
> Some variables are documented with camelCase but read in all
> lowercase in the code. Not worth updating the code just for that, is
> it?

All variables are case-insensitive. The config parser down-cases them, so all code should treat tham as all-lowercase. However, we tend to document them as camelCase for readability.

The completion code should match case-insensitively, too. It doesn't seem to now, but I suspect it is not a problem in practice because the first camelCase word is often enough to get a match, and is lowercase itself.

> I hope none of the added variables are deprecated. After having a
> quick look in git-config(1), I think they should not be.
All looked OK from my quick glance.
One note:
Show 9 quoted lines
>  		color.diff
>  		color.diff.commit
>  		color.diff.frag
> +		color.diff.func
>  		color.diff.meta
>  		color.diff.new
>  		color.diff.old
>  		color.diff.plain
>  		color.diff.whitespace
We have color.diff.branch coming soon (I think it is in 'next' now).
-Peff
Previous: Martin von ZweigbergkNext: Martin von Zweigbergk
Message 2 of 14 in “completion: add missing configuration variables”
  1. completion: add missing configuration variablesMartin von Zweigbergk, Dec 15, 2010
  2. Jeff KingDec 15, 2010
  3. Martin von ZweigbergkDec 15, 2010
  4. Jeff KingDec 16, 2010
  5. Junio C HamanoDec 17, 2010
  6. Jeff KingDec 17, 2010
  7. SZEDER GáborDec 16, 2010
  8. Martin von ZweigbergkDec 16, 2010
  9. Jeff KingDec 16, 2010
  10. Junio C HamanoDec 17, 2010
  11. Jeff KingDec 17, 2010
  12. completion: add missing configuration variablesMartin von Zweigbergk, Dec 20, 2010
  13. Jeff KingDec 20, 2010
  14. Junio C HamanoDec 21, 2010

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.