git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH v3 11/14] reset_head(): take struct rebase_head_opts

From
PWPhillip Wood <phillip.wood123@gmail.com>
Date
Jan 26, 2022, 14:52 UTC
Message-ID
<7b56e91b-a7c9-b7cb-356c-e9615b9459fa@gmail.com>
In-Reply-To
<220126.86fspafwg8.gmgdl@evledraar.gmail.com>
Hi Ævar
On 26/01/2022 13:35, Ævar Arnfjörð Bjarmason wrote:
Show 30 quoted lines
> 
> On Wed, Jan 26 2022, Phillip Wood via GitGitGadget wrote:
> 
>> @@ -669,13 +672,15 @@ static int run_am(struct rebase_options *opts)
>>   
>>   	status = run_command(&format_patch);
>>   	if (status) {
>> +		struct reset_head_opts ropts = { 0 };
>>   		unlink(rebased_patches);
>>   		free(rebased_patches);
>>   		strvec_clear(&am.args);
>>   
>> -		reset_head(the_repository, &opts->orig_head,
>> -			   opts->head_name, 0,
>> -			   NULL, NULL, DEFAULT_REFLOG_ACTION);
>> +		ropts.oid = &opts->orig_head;
>> +		ropts.branch = opts->head_name;
>> +		ropts.default_reflog_action = DEFAULT_REFLOG_ACTION;
>> +		reset_head(the_repository, &ropts);
>>   		error(_("\ngit encountered an error while preparing the "
>>   			"patches to replay\n"
>>   			"these revisions:\n"
> 
> Wouldn't these and the rest be easier to read as:
> 
> 	struct reset_head_opts ropts = {
> 		.oid = &opts->orig_head,
>                  .branch = opts->head_name,
>                  .default_reflog_action = DEFAULT_REFLOG_ACTION,
>          };

I did start out doing something like that but changed to the current style as I felt it made it easier to convert the calls correctly and for reviewers to verify that the conversion is correct when the deletion of the old function arguments is adjacent to the insertion of the new struct assignments and the assignments are in the same order as the old function arguments.

Show 28 quoted lines
> ....
> 
> 
>> @@ -814,14 +819,17 @@ static int rebase_config(const char *var, const char *value, void *data)
>>   static int checkout_up_to_date(struct rebase_options *options)
>>   {
>>   	struct strbuf buf = STRBUF_INIT;
>> +	struct reset_head_opts ropts = { 0 };
>>   	int ret = 0;
>>   
>>   	strbuf_addf(&buf, "%s: checkout %s",
>>   		    getenv(GIT_REFLOG_ACTION_ENVIRONMENT),
>>   		    options->switch_to);
>> -	if (reset_head(the_repository, &options->orig_head,
>> -		       options->head_name, RESET_HEAD_RUN_POST_CHECKOUT_HOOK,
>> -		       NULL, buf.buf, NULL) < 0)
>> +	ropts.oid = &options->orig_head;
>> +	ropts.branch = options->head_name;
>> +	ropts.flags = RESET_HEAD_RUN_POST_CHECKOUT_HOOK;
>> +	ropts.head_msg = buf.buf;
> 
> ...and then for some of the ones like this "ropts.head_msg = buf.buf"
> assignment you just do that one immediately after the strbuf_addf() or
> whatever modifies it.
> 
> That way it's clear what options we get from the function arguments and
> can populate right away, and which ones we need to run some code in the
> function before we can update "ropts".

I'm not immediately clear why that matters. My priority was to keep the assignments in the same order an the old function arguments to make the conversion and review easier.

Show 37 quoted lines
> [Ditto for the elided parts below]
> 
>>   #define GIT_REFLOG_ACTION_ENVIRONMENT "GIT_REFLOG_ACTION"
>>   
>> +/* Request a detached checkout */
>>   #define RESET_HEAD_DETACH (1<<0)
>> +/* Request a reset rather than a checkout */
>>   #define RESET_HEAD_HARD (1<<1)
>> +/* Run the post-checkout hook */
>>   #define RESET_HEAD_RUN_POST_CHECKOUT_HOOK (1<<2)
>> +/* Only update refs, do not touch the worktree */
>>   #define RESET_HEAD_REFS_ONLY (1<<3)
>> +/* Update ORIG_HEAD as well as HEAD */
>>   #define RESET_ORIG_HEAD (1<<4)
>>   
>> -int reset_head(struct repository *r, struct object_id *oid,
>> -	       const char *switch_to_branch, unsigned flags,
>> -	       const char *reflog_orig_head, const char *reflog_head,
>> -	       const char *default_reflog_action);
>> +struct reset_head_opts {
>> +	/*
>> +	 * The commit to checkout/reset to. Defaults to HEAD.
>> +	 */
>> +	const struct object_id *oid;
>> +	/*
>> +	 * Optional branch to switch to.
>> +	 */
>> +	const char *branch;
>> +	/*
>> +	 * Flags defined above.
>> +	 */
>> +	unsigned flags;
> 
> It's nice to make these sort of things an enum type for the reasons
> explained in 3f9ab7ccdea (parse-options.[ch]: consistently use "enum
> parse_opt_flags", 2021-10-08), i.e. gdb and the like will give you the
> labels in the debugger.

Yeah that's true but I'm not actually touching the flags here, just adding comments.

Best Wishes
Phillip
Previous: Ævar Arnfjörð BjarmasonNext: Phillip Wood via GitGitGadget
Message 81 of 85 in “rebase: reset_head() related fixes and improvements”
  1. 00/11 rebase: reset_head() related fixes and improvementsPhillip Wood via GitGitGadget, Oct 1, 2021
  2. 01/11 rebase: factor out checkout for up to date branchPhillip Wood via GitGitGadget, Oct 1, 2021
  3. 03/11 reset_head(): don't run checkout hook if there is an errorPhillip Wood via GitGitGadget, Oct 1, 2021
  4. Junio C HamanoOct 1, 2021
  5. Phillip WoodOct 4, 2021
  6. Ævar Arnfjörð BjarmasonOct 12, 2021
  7. 04/11 reset_head(): remove action parameterPhillip Wood via GitGitGadget, Oct 1, 2021
  8. Junio C HamanoOct 1, 2021
  9. Phillip WoodOct 4, 2021
  10. 05/11 reset_head(): factor out ref updatesPhillip Wood via GitGitGadget, Oct 1, 2021
  11. Junio C HamanoOct 1, 2021
  12. Phillip WoodOct 4, 2021
  13. 06/11 reset_head(): make default_reflog_action optionalPhillip Wood via GitGitGadget, Oct 1, 2021
  14. Junio C HamanoOct 1, 2021
  15. Junio C HamanoOct 1, 2021
  16. Phillip WoodOct 4, 2021
  17. 09/11 rebase --apply: fix reflogPhillip Wood via GitGitGadget, Oct 1, 2021
  18. Junio C HamanoOct 1, 2021
  19. 08/11 reset_head(): take struct rebase_head_optsPhillip Wood via GitGitGadget, Oct 1, 2021
  20. Junio C HamanoOct 1, 2021
  21. Phillip WoodOct 4, 2021
  22. 10/11 rebase --apply: set ORIG_HEAD correctlyPhillip Wood via GitGitGadget, Oct 1, 2021
  23. Junio C HamanoOct 1, 2021
  24. 02/11 reset_head(): fix checkoutPhillip Wood via GitGitGadget, Oct 1, 2021
  25. Junio C HamanoOct 1, 2021
  26. Phillip WoodOct 4, 2021
  27. Junio C HamanoOct 4, 2021
  28. Eric SunshineOct 1, 2021
  29. 11/11 rebase -m: don't fork git checkoutPhillip Wood via GitGitGadget, Oct 1, 2021
  30. 07/11 rebase: cleanup reset_head() callsPhillip Wood via GitGitGadget, Oct 1, 2021
  31. Junio C HamanoOct 2, 2021
  32. Junio C HamanoOct 2, 2021
  33. Phillip WoodOct 2, 2021
  34. Phillip WoodOct 2, 2021
  35. René ScharfeOct 2, 2021
  36. Phillip WoodOct 6, 2021
  37. 00/14 rebase: reset_head() related fixes and improvementsPhillip Wood via GitGitGadget, Dec 8, 2021
  38. 01/14 rebase: factor out checkout for up to date branchPhillip Wood via GitGitGadget, Dec 8, 2021
  39. Junio C HamanoDec 9, 2021
  40. 02/14 t5403: refactor rebase post-checkout hook testsPhillip Wood via GitGitGadget, Dec 8, 2021
  41. Junio C HamanoDec 9, 2021
  42. 03/14 rebase: pass correct arguments to post-checkout hookPhillip Wood via GitGitGadget, Dec 8, 2021
  43. Junio C HamanoDec 9, 2021
  44. 04/14 rebase: do not remove untracked files on checkoutPhillip Wood via GitGitGadget, Dec 8, 2021
  45. Junio C HamanoDec 9, 2021
  46. 05/14 rebase --apply: don't run post-checkout hook if there is an errorPhillip Wood via GitGitGadget, Dec 8, 2021
  47. 06/14 reset_head(): remove action parameterPhillip Wood via GitGitGadget, Dec 8, 2021
  48. 07/14 create_autostash(): remove unneeded parameterPhillip Wood via GitGitGadget, Dec 8, 2021
  49. Junio C HamanoDec 9, 2021
  50. Phillip WoodJan 25, 2022
  51. 08/14 reset_head(): factor out ref updatesPhillip Wood via GitGitGadget, Dec 8, 2021
  52. 09/14 reset_head(): make default_reflog_action optionalPhillip Wood via GitGitGadget, Dec 8, 2021
  53. Junio C HamanoDec 9, 2021
  54. 10/14 rebase: cleanup reset_head() callsPhillip Wood via GitGitGadget, Dec 8, 2021
  55. Junio C HamanoDec 9, 2021
  56. Phillip WoodJan 25, 2022
  57. 11/14 reset_head(): take struct rebase_head_optsPhillip Wood via GitGitGadget, Dec 8, 2021
  58. Junio C HamanoDec 9, 2021
  59. 12/14 rebase --apply: fix reflogPhillip Wood via GitGitGadget, Dec 8, 2021
  60. Junio C HamanoDec 9, 2021
  61. 13/14 rebase --apply: set ORIG_HEAD correctlyPhillip Wood via GitGitGadget, Dec 8, 2021
  62. Elijah NewrenDec 11, 2021
  63. 14/14 rebase -m: don't fork git checkoutPhillip Wood via GitGitGadget, Dec 8, 2021
  64. Junio C HamanoDec 9, 2021
  65. Phillip WoodJan 26, 2022
  66. Junio C HamanoJan 27, 2022
  67. Elijah NewrenDec 11, 2021
  68. 00/14 rebase: reset_head() related fixes and improvementsPhillip Wood via GitGitGadget, Jan 26, 2022
  69. 01/14 rebase: factor out checkout for up to date branchPhillip Wood via GitGitGadget, Jan 26, 2022
  70. 02/14 t5403: refactor rebase post-checkout hook testsPhillip Wood via GitGitGadget, Jan 26, 2022
  71. 03/14 rebase: pass correct arguments to post-checkout hookPhillip Wood via GitGitGadget, Jan 26, 2022
  72. 04/14 rebase: do not remove untracked files on checkoutPhillip Wood via GitGitGadget, Jan 26, 2022
  73. 05/14 rebase --apply: don't run post-checkout hook if there is an errorPhillip Wood via GitGitGadget, Jan 26, 2022
  74. 06/14 reset_head(): remove action parameterPhillip Wood via GitGitGadget, Jan 26, 2022
  75. 07/14 reset_head(): factor out ref updatesPhillip Wood via GitGitGadget, Jan 26, 2022
  76. 08/14 reset_head(): make default_reflog_action optionalPhillip Wood via GitGitGadget, Jan 26, 2022
  77. 09/14 create_autostash(): remove unneeded parameterPhillip Wood via GitGitGadget, Jan 26, 2022
  78. 10/14 rebase: cleanup reset_head() callsPhillip Wood via GitGitGadget, Jan 26, 2022
  79. 11/14 reset_head(): take struct rebase_head_optsPhillip Wood via GitGitGadget, Jan 26, 2022
  80. Ævar Arnfjörð BjarmasonJan 26, 2022
  81. Phillip WoodJan 26, 2022
  82. 12/14 rebase --apply: fix reflogPhillip Wood via GitGitGadget, Jan 26, 2022
  83. 13/14 rebase --apply: set ORIG_HEAD correctlyPhillip Wood via GitGitGadget, Jan 26, 2022
  84. 14/14 rebase -m: don't fork git checkoutPhillip Wood via GitGitGadget, Jan 26, 2022
  85. Elijah NewrenFeb 1, 2022

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.