Re: [PATCH v1 2/6] Status and checkout unit tests for --porcelain[=<n>]
- From
- Jeff Hostetler <git@jeffhostetler.com>
- Date
- Jul 20, 2016, 17:31 UTC
- Message-ID
- <578FB578.5070504@jeffhostetler.com>
- In-Reply-To
- <20160720160357.GA25076@sigill.intra.peff.net>
On 07/20/2016 12:03 PM, Jeff King wrote:
Show 20 quoted lines
> On Wed, Jul 20, 2016 at 10:00:07AM -0600, Jeff King wrote: > >> On Tue, Jul 19, 2016 at 06:10:54PM -0400, Jeff Hostetler wrote: >> >>> +test_expect_failure '--porcelain=bogus with stuff to commit returns ok' ' >>> + echo bongo bongo bongo >>file && >>> + git commit -m next -a --porcelain=bogus >>> +' >> >> Hrm. That seems unexpected to me. Shouldn't it complain about >> --porcelain=bogus? > > Pondering more, did you mean: > > test_expect_success '--porcelain=bogus complains about format' ' > echo bongo bongo bongo >>file && > test_must_fail git commit -m next -a --porcelain=bogus > ' > > ?
Yes. That is what I meant. And yes, some of the names are confusing. Thanks.
Jeff