Re: [PATCH] Also read SQUASH_MSG if a conflict on a merge squash occurred
- From
- Sven Strickroth <sven@cs-ware.de>
- Date
- Mar 8, 2016, 18:49 UTC
- Message-ID
- <56DF1EBD.8050503@cs-ware.de>
- In-Reply-To
- <xmqq60wwlt0s.fsf@gitster.mtv.corp.google.com>
Am 08.03.2016 um 19:32 schrieb Junio C Hamano:
Show 15 quoted lines
>> + if (!stat(git_path_squash_msg(), &statbuf)) {
>> + if (strbuf_read_file(&sb, git_path_squash_msg(), 0) < 0)
>> + die_errno(_("could not read SQUASH_MSG"));
>> + hook_arg1 = "squash";
>> + }
>> } else if (!stat(git_path_squash_msg(), &statbuf)) {
>> if (strbuf_read_file(&sb, git_path_squash_msg(), 0) < 0)
>> die_errno(_("could not read SQUASH_MSG"));
>
> This reads MERGE_MSG first and then SQUASH_MSG; is that what we
> really want? When you are resolving a conflicted rebase, you would
> see the original log message and then conflicts section. What is in
> the SQUASH_MSG is the moral equivalent of the "original log message"
> but in a less summarized form, so I suspect that the list of conflicts
> should come to end.I put them first because the squash commit list could be really long. I'll put MERGE_MSG at the end...
Show 15 quoted lines
> The duplicated code to read the same file bothers me somewhat.
>
> I wondered if it makes the result easier to follow (and easier to
> update) if this part of the code is restructured like this:
>
> if (file_exists(git_path_merge_msg()) ||
> file_exists(git_path_squash_msg())) {
> if (file_exists(git_path_squash_msg())) {
> read SQUASH_MSG;
> }
> if (file_exists(git_path_merge_msg()))
> read MERGE_MSG;
> }
> hook_arg1 = "merge";
> }Here hook_arg1 would be always "merge" and never "squash"... Before my change it was only "squash" if no conflict occurred.
-- Best regards, Sven Strickroth PGP key id F5A9D4C4 @ any key-server