Re: [PATCH 1/2] submodule: fix confusing variable name
- From
Jens Lehmann <jens.lehmann@web.de>
- Date
- Aug 4, 2013, 17:34 UTC
- Message-ID
- <51FE90B8.8030203@web.de>
- In-Reply-To
- <20130803181415.GF2893@elie.Belkin>
Am 03.08.2013 20:14, schrieb Jonathan Nieder:
Show 8 quoted lines
> brian m. carlson wrote: > >> cmd_summary reads the output of git diff, but reads in the submodule >> path into a variable called name. Since this variable does not >> contain the name of the submodule, but the path, rename it to be >> clearer what data it actually holds. > > Nice.
I totally agree. Paths and names of submodules are often confused (especially as they are identical for a submodule that was never moved), so cleaning up our sources so they use the correct term is The Right Thing.
But we'll have to use sm_path here (like everywhere else in the submodule script), because we'll run into problems under Windows otherwise (see 64394e3ae9 for details). Apart from that the patch is fine.